summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-02 15:44:40 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-02 15:44:40 +0000
commitb6541a42b358655234cdd8ae1ab5660d266a1b7b (patch)
tree4b75c408dee58231b5dcc3648d2df6836ebc7d29 /dev-libs/libee
parentAdding runtime dependencies (diff)
downloadgentoo-2-b6541a42b358655234cdd8ae1ab5660d266a1b7b.tar.gz
gentoo-2-b6541a42b358655234cdd8ae1ab5660d266a1b7b.tar.bz2
gentoo-2-b6541a42b358655234cdd8ae1ab5660d266a1b7b.zip
Bump to 0.4.0. Thanks to slepnoga.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libee')
-rw-r--r--dev-libs/libee/ChangeLog7
-rw-r--r--dev-libs/libee/libee-0.4.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-libs/libee/ChangeLog b/dev-libs/libee/ChangeLog
index b9b5a94037e2..f538d3a8b7a8 100644
--- a/dev-libs/libee/ChangeLog
+++ b/dev-libs/libee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/ChangeLog,v 1.7 2012/02/24 15:14:24 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/ChangeLog,v 1.8 2012/03/02 15:44:40 maksbotan Exp $
+
+*libee-0.4.0 (02 Mar 2012)
+
+ 02 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org> +libee-0.4.0.ebuild:
+ Bump to 0.4.0. Thanks to slepnoga.
24 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> libee-0.3.2-r1.ebuild:
x86 stable wrt bug #402161
diff --git a/dev-libs/libee/libee-0.4.0.ebuild b/dev-libs/libee/libee-0.4.0.ebuild
new file mode 100644
index 000000000000..775cfd763f72
--- /dev/null
+++ b/dev-libs/libee/libee-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/libee-0.4.0.ebuild,v 1.1 2012/03/02 15:44:40 maksbotan Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="An Event Expression Library inspired by CEE"
+HOMEPAGE="http://www.libee.org"
+SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libestr"
+RDEPEND="${DEPEND}"
+
+DOCS=(INSTALL ChangeLog)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ --enable-testbench
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+}