summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-01-26 16:51:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-01-26 16:51:43 +0000
commit673e0caed2cf9ce83772b0fad2e4b49a69f86a42 (patch)
tree83a26f661f9b79ad2f818acac44816c33729309d /dev-libs/libev
parentInitial commit. Fixes bug #196300. Ebuild made thanks to ccss.cz. (diff)
downloadgentoo-2-673e0caed2cf9ce83772b0fad2e4b49a69f86a42.tar.gz
gentoo-2-673e0caed2cf9ce83772b0fad2e4b49a69f86a42.tar.bz2
gentoo-2-673e0caed2cf9ce83772b0fad2e4b49a69f86a42.zip
Version bumped. Added static-libs USE flag.
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libev')
-rw-r--r--dev-libs/libev/ChangeLog7
-rw-r--r--dev-libs/libev/libev-4.03.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/libev/ChangeLog b/dev-libs/libev/ChangeLog
index 7ad156675085..a65e52bf3f6b 100644
--- a/dev-libs/libev/ChangeLog
+++ b/dev-libs/libev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.31 2011/01/26 01:06:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.32 2011/01/26 16:51:43 matsuu Exp $
+
+*libev-4.03 (26 Jan 2011)
+
+ 26 Jan 2011; MATSUU Takuto <matsuu@gentoo.org> +libev-4.03.ebuild:
+ Version bumped. Added static-libs USE flag.
26 Jan 2011; Jeroen Roovers <jer@gentoo.org> libev-3.90-r2.ebuild:
Stable for HPPA (bug #349213).
diff --git a/dev-libs/libev/libev-4.03.ebuild b/dev-libs/libev/libev-4.03.ebuild
new file mode 100644
index 000000000000..52f150ae39e0
--- /dev/null
+++ b/dev-libs/libev/libev-4.03.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-4.03.ebuild,v 1.1 2011/01/26 16:51:43 matsuu Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${P}"
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc static-libs"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/4.01-gentoo.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README || die
+}