summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-04 15:53:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-04 15:53:46 +0000
commitc65864ec5264a53974e518082a26835b32f8032e (patch)
treef12a4757c5697a80e7a041085803b632e8f6ac3e /dev-libs/libev
parentVersion bumped. (diff)
downloadgentoo-2-c65864ec5264a53974e518082a26835b32f8032e.tar.gz
gentoo-2-c65864ec5264a53974e518082a26835b32f8032e.tar.bz2
gentoo-2-c65864ec5264a53974e518082a26835b32f8032e.zip
Version bumped.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libev')
-rw-r--r--dev-libs/libev/ChangeLog9
-rw-r--r--dev-libs/libev/libev-3.90.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-libs/libev/ChangeLog b/dev-libs/libev/ChangeLog
index 2a18cd6e5300..47c24a91997d 100644
--- a/dev-libs/libev/ChangeLog
+++ b/dev-libs/libev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libev
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.21 2009/12/14 18:44:37 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.22 2010/01/04 15:53:46 matsuu Exp $
+
+*libev-3.90 (04 Jan 2010)
+
+ 04 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> +libev-3.90.ebuild:
+ Version bumped.
14 Dec 2009; Brent Baude <ranger@gentoo.org> libev-3.80-r1.ebuild:
stable ppc64, bug 294609
diff --git a/dev-libs/libev/libev-3.90.ebuild b/dev-libs/libev/libev-3.90.ebuild
new file mode 100644
index 000000000000..c66a2265b29a
--- /dev/null
+++ b/dev-libs/libev/libev-3.90.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.90.ebuild,v 1.1 2010/01/04 15:53:46 matsuu Exp $
+
+inherit autotools eutils
+
+MY_P="${P/0}"
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Bug #283558
+DEPEND=">=sys-libs/glibc-2.9_p20081201"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README
+}