summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-22 14:44:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-22 14:44:39 +0000
commitee227a6dab4c6b193396a57823b19dd2a6e188a0 (patch)
treef7278eeec965d1488da21a535a772a93289cf986 /dev-libs/libgcrypt
parentversion bump (diff)
downloadgentoo-2-ee227a6dab4c6b193396a57823b19dd2a6e188a0.tar.gz
gentoo-2-ee227a6dab4c6b193396a57823b19dd2a6e188a0.tar.bz2
gentoo-2-ee227a6dab4c6b193396a57823b19dd2a6e188a0.zip
Revbump: also drop -L flags from libgcrypt-config as done for libgpg-error; avoid forcing PIC code for static libraries (if they are even enabled); use EAPI=4 features; remove .la files if the static libraries are not installed.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog10
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-multilib-syspath.patch23
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.5.0-r1.ebuild44
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 59112756adff..8f4fb6565338 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libgcrypt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.151 2011/09/22 14:21:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.152 2011/09/22 14:44:39 flameeyes Exp $
+
+*libgcrypt-1.5.0-r1 (22 Sep 2011)
+
+ 22 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libgcrypt-1.5.0-r1.ebuild, +files/libgcrypt-multilib-syspath.patch:
+ Revbump: also drop -L flags from libgcrypt-config as done for libgpg-error;
+ avoid forcing PIC code for static libraries (if they are even enabled); use
+ EAPI=4 features; remove .la files if the static libraries are not installed.
22 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org>
-libgcrypt-1.5.0_beta1-r1.ebuild, -libgcrypt-1.5.0_beta1-r2.ebuild,
diff --git a/dev-libs/libgcrypt/files/libgcrypt-multilib-syspath.patch b/dev-libs/libgcrypt/files/libgcrypt-multilib-syspath.patch
new file mode 100644
index 000000000000..7859851ccc4a
--- /dev/null
+++ b/dev-libs/libgcrypt/files/libgcrypt-multilib-syspath.patch
@@ -0,0 +1,23 @@
+diff --git a/src/libgcrypt-config.in b/src/libgcrypt-config.in
+index c052638..4c8ddc3 100644
+--- a/src/libgcrypt-config.in
++++ b/src/libgcrypt-config.in
+@@ -154,9 +154,12 @@ if test "$echo_libs" = "yes"; then
+ libs_final="$libs"
+
+ # Set up `libdirs'.
+- if test "x$libdir" != "x/usr/lib" -a "x$libdir" != "x/lib"; then
+- libdirs="-L$libdir"
+- fi
++ case "$libdir" in
++ /usr/lib|/usr/lib64|/lib|/lib64) ;;
++ *)
++ libdirs="-L$libdir"
++ ;;
++ esac
+
+ # Set up `libs_final'.
+ libs_final="$libs_final $gpg_error_libs"
+--
+1.7.6.1
+
diff --git a/dev-libs/libgcrypt/libgcrypt-1.5.0-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..5bc754f272b7
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.5.0-r1.ebuild,v 1.1 2011/09/22 14:44:39 flameeyes Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
+ ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-uscore.patch
+ epatch "${FILESDIR}"/${PN}-multilib-syspath.patch
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-padlock-support for bug #201917
+ econf \
+ --disable-padlock-support \
+ --disable-dependency-tracking \
+ --enable-noexecstack \
+ --disable-O-flag-munging \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}