summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-21 09:04:07 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-21 09:04:07 +0000
commita96f21ac6ca6a3c4a66c259bf874fadabe243f82 (patch)
tree6033e5b0c82733486c04ae9716578b877b2fad74 /dev-libs/libgit2
parentVersion bump. (diff)
downloadgentoo-2-a96f21ac6ca6a3c4a66c259bf874fadabe243f82.tar.gz
gentoo-2-a96f21ac6ca6a3c4a66c259bf874fadabe243f82.tar.bz2
gentoo-2-a96f21ac6ca6a3c4a66c259bf874fadabe243f82.zip
Remove old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/ChangeLog6
-rw-r--r--dev-libs/libgit2/libgit2-0.19.0.ebuild39
-rw-r--r--dev-libs/libgit2/libgit2-0.20.0.ebuild63
3 files changed, 5 insertions, 103 deletions
diff --git a/dev-libs/libgit2/ChangeLog b/dev-libs/libgit2/ChangeLog
index fd15a5ccf0bd..b11d0f8bf8e4 100644
--- a/dev-libs/libgit2/ChangeLog
+++ b/dev-libs/libgit2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libgit2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgit2/ChangeLog,v 1.22 2014/06/21 09:03:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgit2/ChangeLog,v 1.23 2014/06/21 09:04:07 radhermit Exp $
+
+ 21 Jun 2014; Tim Harder <radhermit@gentoo.org> -libgit2-0.19.0.ebuild,
+ -libgit2-0.20.0.ebuild:
+ Remove old.
*libgit2-0.21.0 (21 Jun 2014)
diff --git a/dev-libs/libgit2/libgit2-0.19.0.ebuild b/dev-libs/libgit2/libgit2-0.19.0.ebuild
deleted file mode 100644
index c4fa3b7d97fc..000000000000
--- a/dev-libs/libgit2/libgit2-0.19.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgit2/libgit2-0.19.0.ebuild,v 1.1 2013/06/25 18:19:57 radhermit Exp $
-
-EAPI=5
-
-inherit cmake-utils multilib
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="http://libgit2.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc-macos"
-IUSE="examples test"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- $(cmake-utils_use_build test CLAR)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use examples ; then
- find examples -name .gitignore -delete
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-libs/libgit2/libgit2-0.20.0.ebuild b/dev-libs/libgit2/libgit2-0.20.0.ebuild
deleted file mode 100644
index 3c9f2fe84fe8..000000000000
--- a/dev-libs/libgit2/libgit2-0.20.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgit2/libgit2-0.20.0.ebuild,v 1.1 2013/11/24 23:06:29 radhermit Exp $
-
-EAPI=5
-
-inherit cmake-utils multilib
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="http://libgit2.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc-macos"
-IUSE="examples ssh test trace"
-
-RDEPEND="sys-libs/zlib
- net-libs/http-parser
- ssh? ( net-libs/libssh2 )"
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-PATCHES=( "${FILESDIR}"/${P}-skip-blame-test.patch )
-
-src_prepare() {
- # skip online tests
- sed -i '/libgit2_clar/s/-ionline/-xonline/' CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- $(cmake-utils_use_build test CLAR)
- $(cmake-utils_use_enable trace TRACE)
- $(cmake-utils_use_use ssh SSH)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake-utils_src_test
- fi
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use examples ; then
- find examples -name .gitignore -delete
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}