summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-03-06 11:42:39 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-03-06 11:42:39 +0000
commit62d38ec2429695c749287b91a9c72efa177279d2 (patch)
treecf0b233d71f87b23fcc57e31d84bb4c2e0d179a8 /dev-libs/libgpg-error
parentVersion bump, per bug#460340 (diff)
downloadgentoo-2-62d38ec2429695c749287b91a9c72efa177279d2.tar.gz
gentoo-2-62d38ec2429695c749287b91a9c72efa177279d2.tar.bz2
gentoo-2-62d38ec2429695c749287b91a9c72efa177279d2.zip
Version bump, per bug#460338
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-libs/libgpg-error')
-rw-r--r--dev-libs/libgpg-error/ChangeLog7
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.11.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/libgpg-error/ChangeLog b/dev-libs/libgpg-error/ChangeLog
index 1cb627bc3742..010327319c28 100644
--- a/dev-libs/libgpg-error/ChangeLog
+++ b/dev-libs/libgpg-error/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgpg-error
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/ChangeLog,v 1.86 2013/02/19 04:06:27 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/ChangeLog,v 1.87 2013/03/06 11:42:39 alonbl Exp $
+
+*libgpg-error-1.11 (06 Mar 2013)
+
+ 06 Mar 2013; Alon Bar-Lev <alonbl@gentoo.org> +libgpg-error-1.11.ebuild:
+ Version bump, per bug#460338
19 Feb 2013; Zac Medico <zmedico@gentoo.org> libgpg-error-1.10-r1.ebuild,
libgpg-error-1.10.ebuild:
diff --git a/dev-libs/libgpg-error/libgpg-error-1.11.ebuild b/dev-libs/libgpg-error/libgpg-error-1.11.ebuild
new file mode 100644
index 000000000000..b07724d943d6
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.11.ebuild,v 1.1 2013/03/06 11:42:39 alonbl Exp $
+
+EAPI="4"
+
+inherit libtool
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE_LINGUAS=" cs de fr it nl pl ro sv vi zh_CN"
+IUSE="common-lisp nls static-libs ${IUSE_LINGUAS// / linguas_}"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ elibtoolize
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable common-lisp languages)
+}
+
+src_install() {
+ default
+
+ # library has no dependencies, so it does not need the .la file
+ find "${D}" -name '*.la' -delete
+}