summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 16:26:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 16:26:24 +0000
commit30a646f31e4c4b38ebf7df625f81d9667eb1cf71 (patch)
tree20fd31400eef9f42c98be8afd3e73647937d05f0 /dev-libs/libgweather
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-30a646f31e4c4b38ebf7df625f81d9667eb1cf71.tar.gz
gentoo-2-30a646f31e4c4b38ebf7df625f81d9667eb1cf71.tar.bz2
gentoo-2-30a646f31e4c4b38ebf7df625f81d9667eb1cf71.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog8
-rw-r--r--dev-libs/libgweather/libgweather-3.12.1.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 1791da8b46dc..0a6ff404f322 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.107 2014/04/26 06:52:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.108 2014/04/27 16:26:24 eva Exp $
+
+*libgweather-3.12.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgweather-3.12.1.ebuild:
+ Version bump for Gnome 3.12.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -libgweather-3.10.1.ebuild,
-libgweather-3.8.3.ebuild:
diff --git a/dev-libs/libgweather/libgweather-3.12.1.ebuild b/dev-libs/libgweather/libgweather-3.12.1.ebuild
new file mode 100644
index 000000000000..6485b6737f9c
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.12.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-3.12.1.ebuild,v 1.1 2014/04/27 16:26:24 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.34:2.4
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}