summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-03 15:35:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-03 15:35:06 +0000
commitfe956d46689dd3f067dacf31aa2948aa0a4b8571 (patch)
treed757127ed29b543976b4fa493f5b7fa5fdb881ec /dev-libs/libspt
parentMarked ppc/ppc64 stable for bug #262744. (diff)
downloadgentoo-2-fe956d46689dd3f067dacf31aa2948aa0a4b8571.tar.gz
gentoo-2-fe956d46689dd3f067dacf31aa2948aa0a4b8571.tar.bz2
gentoo-2-fe956d46689dd3f067dacf31aa2948aa0a4b8571.zip
Patch to fix compilation with gcc43 from Magnus Granberg. EAPI2ified. Fixes #260886
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libspt')
-rw-r--r--dev-libs/libspt/ChangeLog11
-rw-r--r--dev-libs/libspt/files/libspt-werror.patch11
-rw-r--r--dev-libs/libspt/libspt-1.1-r1.ebuild27
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-libs/libspt/ChangeLog b/dev-libs/libspt/ChangeLog
index ab45492bac00..56add82437f4 100644
--- a/dev-libs/libspt/ChangeLog
+++ b/dev-libs/libspt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libspt
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libspt/ChangeLog,v 1.5 2007/02/09 02:33:54 flameeyes Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libspt/ChangeLog,v 1.6 2009/04/03 15:35:05 patrick Exp $
+
+*libspt-1.1-r1 (03 Apr 2009)
+
+ 03 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/libspt-werror.patch, +libspt-1.1-r1.ebuild:
+ Patch to fix compilation with gcc43 from Magnus Granberg. EAPI2ified.
+ Fixes #260886
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-libs/libspt/files/libspt-werror.patch b/dev-libs/libspt/files/libspt-werror.patch
new file mode 100644
index 000000000000..6190ea5a4556
--- /dev/null
+++ b/dev-libs/libspt/files/libspt-werror.patch
@@ -0,0 +1,11 @@
+--- Makefile.in 2003-12-07 06:42:15.000000000 +0000
++++ Makefile.in 2009-03-10 21:09:43.000000000 +0000
+@@ -29,7 +29,7 @@
+ INCLUDES = -I.
+ DEFS = @DEFS@
+ CC = @CC@
+-COMMONCFLAGS = -Wall -g -Werror -pipe
++COMMONCFLAGS = -Wall -g -pipe
+ CFLAGS = $(COMMONCFLAGS) @CFLAGS@
+ INSTALL = $(LIBTOOL) --mode=install @INSTALL@
+ INSTALL_DATA = $(LIBTOOL) --mode=install @INSTALL@ -m 644
diff --git a/dev-libs/libspt/libspt-1.1-r1.ebuild b/dev-libs/libspt/libspt-1.1-r1.ebuild
new file mode 100644
index 000000000000..23fc912be4b7
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libspt/libspt-1.1-r1.ebuild,v 1.1 2009/04/03 15:35:05 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="Library for handling root privilege"
+HOMEPAGE="http://www.j10n.org/libspt/index.html"
+SRC_URI="http://www.j10n.org/libspt/${P}.tar.bz2"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+inherit eutils
+
+src_prepare() {
+ epatch "${FILESDIR}/libspt-werror.patch"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" mandir=/usr/share/man install || die
+ dodoc CHANGES
+}