summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-22 22:59:23 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-22 22:59:23 +0000
commit4eb311ca578d9c7f72883a9bc2b1ad6bb278fa4d (patch)
tree7fd143921edd10df122b6e302344a08beddeeb68 /dev-libs/libsqlora8
parentthreads goes global (diff)
downloadgentoo-2-4eb311ca578d9c7f72883a9bc2b1ad6bb278fa4d.tar.gz
gentoo-2-4eb311ca578d9c7f72883a9bc2b1ad6bb278fa4d.tar.bz2
gentoo-2-4eb311ca578d9c7f72883a9bc2b1ad6bb278fa4d.zip
pthreads -> threads
(Portage version: 2.0.51-r14)
Diffstat (limited to 'dev-libs/libsqlora8')
-rw-r--r--dev-libs/libsqlora8/ChangeLog7
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild12
2 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/libsqlora8/ChangeLog b/dev-libs/libsqlora8/ChangeLog
index 9d79ca3bd97a..4edefabc6205 100644
--- a/dev-libs/libsqlora8/ChangeLog
+++ b/dev-libs/libsqlora8/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libsqlora8
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/ChangeLog,v 1.4 2004/06/25 19:30:37 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/ChangeLog,v 1.5 2005/01/22 22:58:36 dragonheart Exp $
+
+ 23 Jan 2005; Daniel Black <dragonheart@gentoo.org> libsqlora8-2.2.11.ebuild:
+ threads is now a global use flags. Changed pthreads to threads.
25 Jun 2004; Aron Griffis <agriffis@gentoo.org> libsqlora8-2.2.11.ebuild:
QA - fix use invocation
diff --git a/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild b/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild
index aa9ede59b2ab..19cda26df78a 100644
--- a/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild
+++ b/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild,v 1.4 2004/06/25 19:30:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/libsqlora8-2.2.11.ebuild,v 1.5 2005/01/22 22:58:36 dragonheart Exp $
-IUSE="pthreads orathreads"
+IUSE="threads orathreads"
DESCRIPTION="libsqlora8 is a simple C-library to access Oracle databases via the OCI interface"
SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
@@ -15,12 +15,12 @@ KEYWORDS="~x86"
DEPEND=""
pkg_setup() {
- if use orathreads && use pthreads; then
+ if use orathreads && use threads; then
eerror
- eerror 'Enable the "pthreads" USE flag for POSIX threads,'
+ eerror 'Enable the "threads" USE flag for POSIX threads,'
eerror '*or* the "orathreads" USE flag for Oracle threads'
eerror
- die 'Both "pthreads" and "orathreads" USE flags set, see above'
+ die 'Both "threads" and "orathreads" USE flags set, see above'
fi
# Make sure ORACLE_HOME is set
@@ -45,7 +45,7 @@ src_compile() {
export LD_LIBRARY_PATH
- use pthreads && myconf="--with-threads=posix"
+ use threads && myconf="--with-threads=posix"
use orathreads && myconf="--with-threads=oracle"
# Build