summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-12-07 11:27:04 +0000
committerThilo Bangert <bangert@gentoo.org>2009-12-07 11:27:04 +0000
commitda703d91de7f29f4246f198b7545e8f6c5f81d9b (patch)
tree69e46b18584ca78153696a0261f864bf865be11c /dev-libs/libtomcrypt
parentamd64/arm stable, bug #295405 (diff)
downloadgentoo-2-da703d91de7f29f4246f198b7545e8f6c5f81d9b.tar.gz
gentoo-2-da703d91de7f29f4246f198b7545e8f6c5f81d9b.tar.bz2
gentoo-2-da703d91de7f29f4246f198b7545e8f6c5f81d9b.zip
rework patches so they apply (bug #245998) - fix doc install location - disables tests
(Portage version: 2.2_rc56/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libtomcrypt')
-rw-r--r--dev-libs/libtomcrypt/ChangeLog8
-rw-r--r--dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.diff41
-rw-r--r--dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.shared.diff28
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild17
4 files changed, 86 insertions, 8 deletions
diff --git a/dev-libs/libtomcrypt/ChangeLog b/dev-libs/libtomcrypt/ChangeLog
index ffa522a8a14f..8f10e5f64d7b 100644
--- a/dev-libs/libtomcrypt/ChangeLog
+++ b/dev-libs/libtomcrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libtomcrypt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.36 2009/04/03 19:33:54 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.37 2009/12/07 11:27:04 bangert Exp $
+
+ 07 Dec 2009; Thilo Bangert <bangert@gentoo.org> libtomcrypt-1.06.ebuild,
+ +files/libtomcrypt-1.06-makefile.diff,
+ +files/libtomcrypt-1.06-makefile.shared.diff:
+ rework patches so they apply (bug #245998) - fix doc install location -
+ disables tests
03 Apr 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
libtomcrypt-1.17-r3.ebuild:
diff --git a/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.diff b/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.diff
new file mode 100644
index 000000000000..b165e311749a
--- /dev/null
+++ b/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.diff
@@ -0,0 +1,41 @@
+--- makefile 2005-08-01 13:33:58.000000000 -0400
++++ makefile 2005-08-07 19:41:08.000000000 -0400
+@@ -4,7 +4,7 @@
+ # Modified by Clay Culver
+
+ # The version
+-VERSION=1.06
++VERSION=1.07
+
+ # Compiler and Linker Names
+ #CC=gcc
+@@ -254,16 +254,16 @@
+ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+ install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DESTDIR)$(DATAPATH)
+
+-install_test: $(LIBTEST)
++install_test: testprof/$(LIBTEST)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+- install -g $(GROUP) -o $(USER) $(LIBTEST) $(DESTDIR)$(LIBPATH)
++ install -g $(GROUP) -o $(USER) testprof/$(LIBTEST) $(DESTDIR)$(LIBPATH)
+
+ profile:
+- CFLAGS="$(CFLAGS) -fprofile-generate" make timing EXTRALIBS=-lgcov
++ CFLAGS="$(CFLAGS) -fprofile-generate" make timing EXTRALIBS="$(EXTRALIBS) -lgcov"
+ ./timing
+ rm -f timing `find . -type f | grep [.][ao] | xargs`
+- CFLAGS="$(CFLAGS) -fprofile-use" make timing EXTRALIBS=-lgcov
++ CFLAGS="$(CFLAGS) -fprofile-use" make timing EXTRALIBS="$(EXTRALIBS) -lgcov"
+
+
+ #This rule cleans the source tree of all compiled code, not including the pdf
+@@ -333,6 +333,6 @@
+
+
+ # $Source: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.diff,v $
+-# $Revision: 1.1 $
+-# $Date: 2009/12/07 11:27:03 $
++# $Revision: 1.1 $
++# $Date: 2009/12/07 11:27:03 $
+
diff --git a/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.shared.diff b/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.shared.diff
new file mode 100644
index 000000000000..c3288d57a333
--- /dev/null
+++ b/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.shared.diff
@@ -0,0 +1,28 @@
+--- makefile.shared 2005-08-01 13:33:58.000000000 -0400
++++ makefile.shared 2005-08-07 19:41:08.000000000 -0400
+@@ -6,7 +6,7 @@
+ # Tom St Denis
+
+ # The version
+-VERSION=0:106
++VERSION=0:107
+
+ # Compiler and Linker Names
+ CC=libtool --mode=compile gcc
+@@ -205,7 +205,7 @@
+ testprof/$(LIBTEST):
+ cd testprof ; CFLAGS="$(CFLAGS)" GROUP=$(GROUP) USER=$(USER) VERSION=$(VERSION) LIBPATH=$(LIBPATH) LIBTEST=$(LIBTEST) LIBTEST_S=$(LIBTEST_S) make -f makefile.shared
+
+-$(LIBNAME): $(OBJECTS)
++$(LIBNAME): $(OBJECTS) testprof/$(LIBTEST)
+ libtool --silent --mode=link gcc $(CFLAGS) `find . -type f | grep "[.]lo" | grep "src/" | xargs` $(EXTRALIBS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+ libtool --silent --mode=link gcc $(CFLAGS) `find . -type f | grep "[.]o" | grep "src/" | xargs` $(EXTRALIBS) -o $(LIBNAME_S)
+ ranlib $(LIBNAME_S)
+@@ -233,5 +233,5 @@
+ gcc -o $(TIMING) $(TIMINGS) -ltomcrypt_prof -ltomcrypt $(EXTRALIBS)
+
+ # $Source: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/files/libtomcrypt-1.06-makefile.shared.diff,v $
+-# $Revision: 1.1 $
+-# $Date: 2009/12/07 11:27:03 $
++# $Revision: 1.1 $
++# $Date: 2009/12/07 11:27:03 $
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild
index bd990786c31c..27c9c7469d7a 100644
--- a/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild,v 1.5 2008/09/05 07:38:45 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.06.ebuild,v 1.6 2009/12/07 11:27:04 bangert Exp $
inherit eutils flag-o-matic
DESCRIPTION="modular and portable cryptographic toolkit"
HOMEPAGE="http://libtomcrypt.org/"
-SRC_URI="http://libtomcrypt.org/files/crypt-${PV}.tar.bz2
- http://libtomcrypt.org/files/patch-1.06/makefile.diff
- http://libtomcrypt.org/files/patch-1.06/makefile.shared.diff"
+SRC_URI="http://libtomcrypt.org/files/crypt-${PV}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
@@ -24,7 +22,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack crypt-${PV}.tar.bz2
cd "${S}"
- epatch "${DISTDIR}"/makefile{,.shared}.diff
+ epatch "${FILESDIR}"/libtomcrypt-1.06-makefile{,.shared}.diff
use doc || sed -i '/^install:/s:docs::' makefile
}
@@ -34,8 +32,13 @@ src_compile() {
emake IGNORE_SPEED=1 || die
}
+src_test() {
+ # Tests don't compile
+ true
+}
+
src_install() {
- make DESTDIR="${D}" install || die
+ make DESTDIR="${D}" DATAPATH="/usr/share/doc/${P}" install || die
dodoc TODO changes
if use doc ; then
dodoc doc/*