summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-06-17 18:58:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-06-17 18:58:24 +0000
commit4827eb6af7e53193e6460a0b64a2eee86eff1bae (patch)
tree700b3bb39a9cc7b4bb5f59eb2d35f5b09dd100b6 /dev-libs/libusb
parentVersion bump for Gnome 2.30 (diff)
downloadgentoo-2-4827eb6af7e53193e6460a0b64a2eee86eff1bae.tar.gz
gentoo-2-4827eb6af7e53193e6460a0b64a2eee86eff1bae.tar.bz2
gentoo-2-4827eb6af7e53193e6460a0b64a2eee86eff1bae.zip
Bug #320151: Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libusb')
-rw-r--r--dev-libs/libusb/ChangeLog7
-rw-r--r--dev-libs/libusb/libusb-1.0.8.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/libusb/ChangeLog b/dev-libs/libusb/ChangeLog
index 2881d5aeeb2e..42f30a148de2 100644
--- a/dev-libs/libusb/ChangeLog
+++ b/dev-libs/libusb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libusb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/ChangeLog,v 1.101 2010/05/02 21:52:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/ChangeLog,v 1.102 2010/06/17 18:58:24 robbat2 Exp $
+
+*libusb-1.0.8 (17 Jun 2010)
+
+ 17 Jun 2010; Robin H. Johnson <robbat2@gentoo.org> +libusb-1.0.8.ebuild:
+ Bug #320151: Version bump.
*libusb-1.0.7 (02 May 2010)
diff --git a/dev-libs/libusb/libusb-1.0.8.ebuild b/dev-libs/libusb/libusb-1.0.8.ebuild
new file mode 100644
index 000000000000..d4632aa363b2
--- /dev/null
+++ b/dev-libs/libusb/libusb-1.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-1.0.8.ebuild,v 1.1 2010/06/17 18:58:24 robbat2 Exp $
+
+EAPI="2"
+
+DESCRIPTION="Userspace access to USB devices"
+HOMEPAGE="http://libusb.org/"
+SRC_URI="mirror://sourceforge/libusb/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug debug-log)
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd doc
+ emake docs || die "making docs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS PORTING README THANKS TODO
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+
+ dohtml doc/html/*
+ fi
+}