summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-11 12:41:25 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-11 12:41:25 +0000
commit8f1a9f5407e539452d738bc44c209b8477cf7912 (patch)
treec463ca088b5429ad8512005d2eb44122411dd4d2 /dev-libs/libx86
parentMigrate to distutils-r1. Start test server on a semi-random unocuppied port. (diff)
downloadgentoo-2-8f1a9f5407e539452d738bc44c209b8477cf7912.tar.gz
gentoo-2-8f1a9f5407e539452d738bc44c209b8477cf7912.tar.bz2
gentoo-2-8f1a9f5407e539452d738bc44c209b8477cf7912.zip
Revision bump: install static libs optionally, wrt bug #456648
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libx86')
-rw-r--r--dev-libs/libx86/ChangeLog8
-rw-r--r--dev-libs/libx86/files/libx86-1.1-makefile.patch28
-rw-r--r--dev-libs/libx86/libx86-1.1-r3.ebuild44
3 files changed, 79 insertions, 1 deletions
diff --git a/dev-libs/libx86/ChangeLog b/dev-libs/libx86/ChangeLog
index e0b043aec295..da35b1a651b6 100644
--- a/dev-libs/libx86/ChangeLog
+++ b/dev-libs/libx86/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libx86
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libx86/ChangeLog,v 1.18 2013/02/10 14:52:44 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libx86/ChangeLog,v 1.19 2013/02/11 12:41:25 pinkbyte Exp $
+
+*libx86-1.1-r3 (11 Feb 2013)
+
+ 11 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +libx86-1.1-r3.ebuild,
+ +files/libx86-1.1-makefile.patch:
+ Revision bump: install static libs optionally, wrt bug #456648
10 Feb 2013; Michael Palimaka <kensington@gentoo.org> -libx86-1.1-r1.ebuild:
Remove old.
diff --git a/dev-libs/libx86/files/libx86-1.1-makefile.patch b/dev-libs/libx86/files/libx86-1.1-makefile.patch
new file mode 100644
index 000000000000..471c3fbc78fd
--- /dev/null
+++ b/dev-libs/libx86/files/libx86-1.1-makefile.patch
@@ -0,0 +1,28 @@
+--- Makefile.orig 2013-02-11 16:35:56.834368910 +0400
++++ Makefile 2013-02-11 16:36:02.587369368 +0400
+@@ -22,7 +22,7 @@
+ $(AR) cru libx86.a $(OBJECTS)
+
+ shared: $(OBJECTS)
+- $(CC) $(CFLAGS) -o libx86.so.1 -shared -Wl,-soname,libx86.so.1 $(OBJECTS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o libx86.so.1 -shared -Wl,-soname,libx86.so.1 $(OBJECTS)
+
+ objclean:
+ $(MAKE) -C x86emu clean
+@@ -31,8 +31,14 @@
+ clean: objclean
+ rm -f *.so.1 *.a
+
+-install: libx86.so.1
++install-shared: libx86.so.1
+ install -D libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so.1
+- install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
+ ln -sf libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so
++
++install-header:
+ install -p -m 0644 -D lrmi.h $(DESTDIR)/usr/include/libx86.h
++
++install-static:
++ install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
++
++install: install-shared install-static install-header
diff --git a/dev-libs/libx86/libx86-1.1-r3.ebuild b/dev-libs/libx86/libx86-1.1-r3.ebuild
new file mode 100644
index 000000000000..62609313a199
--- /dev/null
+++ b/dev-libs/libx86/libx86-1.1-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libx86/libx86-1.1-r3.ebuild,v 1.1 2013/02/11 12:41:25 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
+HOMEPAGE="http://www.codon.org.uk/~mjg59/libx86"
+SRC_URI="http://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ # fix compile failure with linux-headers-2.6.26, bug 235599
+ epatch "${FILESDIR}"/${PN}-0.99-ifmask.patch
+ # Patch for bugs #236888 and #456648
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ tc-export CC AR
+}
+
+src_compile() {
+ local ARGS
+ use amd64 && ARGS="BACKEND=x86emu"
+ emake ${ARGS} LIBRARY=shared shared
+ if use static-libs; then
+ emake ${ARGS} objclean
+ emake ${ARGS} LIBRARY=static static
+ fi
+}
+
+src_install() {
+ local install_static;
+ use static-libs && install_static='install-static'
+ emake \
+ LIBDIR="/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install-header install-shared ${install_static}
+}