summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-16 08:05:17 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-16 08:05:17 +0000
commitce39e5e2a17510c50f244e1124fa8c80fd92919e (patch)
tree972121e3c6f9d0f470ab25e22ab8a0e9d28c44e6 /dev-libs/libxml2
parentVersion bump, this fixes proprietary flash crashing the page on Gentoo: the p... (diff)
downloadgentoo-2-ce39e5e2a17510c50f244e1124fa8c80fd92919e.tar.gz
gentoo-2-ce39e5e2a17510c50f244e1124fa8c80fd92919e.tar.bz2
gentoo-2-ce39e5e2a17510c50f244e1124fa8c80fd92919e.zip
Fix inkscape extension loader problem per bug #285125, patch import from upstream bug #595128, thanks to Andreas Proteus <proteuss@sdf.lonestar.org> for tests
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog10
-rw-r--r--dev-libs/libxml2/files/libxml2-2.7.4-parser-grow.patch34
-rw-r--r--dev-libs/libxml2/libxml2-2.7.4-r1.ebuild141
3 files changed, 184 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index d6fdc58618a2..63dc6c0ef84e 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.273 2009/09/13 23:05:47 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.274 2009/09/16 08:05:17 mrpouet Exp $
+
+*libxml2-2.7.4-r1 (16 Sep 2009)
+
+ 16 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ +libxml2-2.7.4-r1.ebuild, +files/libxml2-2.7.4-parser-grow.patch:
+ Fix inkscape extension loader problem per bug #285125, patch import from
+ upstream bug #595128, thanks to Andreas Proteus
+ <proteuss@sdf.lonestar.org> for tests.
*libxml2-2.7.4 (13 Sep 2009)
diff --git a/dev-libs/libxml2/files/libxml2-2.7.4-parser-grow.patch b/dev-libs/libxml2/files/libxml2-2.7.4-parser-grow.patch
new file mode 100644
index 000000000000..8784a83ec459
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.7.4-parser-grow.patch
@@ -0,0 +1,34 @@
+From 9d3d141c412baa5c713ad3df48f1a4d179e07b05 Mon Sep 17 00:00:00 2001
+From: Daniel Veillard <veillard@redhat.com>
+Date: Tue, 15 Sep 2009 16:41:30 +0000
+Subject: Fix a parsing problem with little data at startup
+
+* parser.c: inkscape extension loader (and possibly others) feed
+ data to the parser very slowly, 0 at start, 4 bytes on first GROW
+ and this broke after the fix for
+ https://bugzilla.gnome.org/show_bug.cgi?id=566012
+ http://git.gnome.org/cgit/libxml2/commit/?id=7e385bd4e28a0cc12b6b26ed178c620e3c3ab8d8
+ leading to another bug
+ https://bugzilla.redhat.com/show_bug.cgi?id=523002
+ this detects the situation and GROW when needed for proper processing.
+---
+diff --git a/parser.c b/parser.c
+index e415339..b41dcc3 100644
+--- a/parser.c
++++ b/parser.c
+@@ -10130,8 +10130,12 @@ xmlParseDocument(xmlParserCtxtPtr ctxt) {
+ /*
+ * Check for the XMLDecl in the Prolog.
+ * do not GROW here to avoid the detected encoder to decode more
+- * than just the first line
++ * than just the first line, unless the amount of data is really
++ * too small to hold "<?xml version="1.0" encoding="foo"
+ */
++ if ((ctxt->input->end - ctxt->input->cur) < 35) {
++ GROW;
++ }
+ if ((CMP5(CUR_PTR, '<', '?', 'x', 'm', 'l')) && (IS_BLANK_CH(NXT(5)))) {
+
+ /*
+--
+cgit v0.8.2
diff --git a/dev-libs/libxml2/libxml2-2.7.4-r1.ebuild b/dev-libs/libxml2/libxml2-2.7.4-r1.ebuild
new file mode 100644
index 000000000000..e3e46bbd0aed
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.7.4-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.4-r1.ebuild,v 1.1 2009/09/16 08:05:17 mrpouet Exp $
+
+EAPI="2"
+
+inherit libtool flag-o-matic eutils python
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc examples ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ # ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ if use test; then
+ cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+ "${DISTDIR}/${XSTS_TARBALL_2}" \
+ "${S}"/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+
+ # Fix inkscape extension loader problem, bug #285125,
+ # patch import from upstream bug #595128.
+ epatch "${FILESDIR}"/${P}-parser-grow.patch
+}
+
+src_prepare() {
+ epunt_cxx
+}
+
+src_configure() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ --with-html-subdir=${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable ipv6) \
+ PYTHON_SITE_PACKAGES=$(python_get_sitedir)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/examples \
+ docsdir=/usr/share/doc/${PF}/python \
+ exampledir=/usr/share/doc/${PF}/python/examples \
+ install || die "Installation failed"
+
+ rm "${D}"/usr/share/doc/${P}/{AUTHORS,ChangeLog,Copyright,NEWS,README*,TODO*}
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO* || die "dodoc failed"
+
+ if ! use python; then
+ rm -rf "${D}"/usr/share/doc/${PF}/python
+ rm -rf "${D}"/usr/share/doc/${PN}-python-${PV}
+ fi
+
+ if ! use doc; then
+ rm -rf "${D}"/usr/share/gtk-doc
+ rm -rf "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ rm -rf "${D}/usr/share/doc/${PF}/python/examples"
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)
+ fi
+
+ # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+ # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+ if [ "${ROOT}" != "/" ]
+ then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
+}