summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-05-03 01:32:35 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-05-03 01:32:35 +0000
commit06749845729432534464d9ef9d0c46eb31b710d9 (patch)
tree82faab61bd5e8832c9b814b31f9213ea36b265f8 /dev-libs/log4c
parentfixes (diff)
downloadgentoo-2-06749845729432534464d9ef9d0c46eb31b710d9.tar.gz
gentoo-2-06749845729432534464d9ef9d0c46eb31b710d9.tar.bz2
gentoo-2-06749845729432534464d9ef9d0c46eb31b710d9.zip
New ebuild.
Diffstat (limited to 'dev-libs/log4c')
-rw-r--r--dev-libs/log4c/ChangeLog15
-rw-r--r--dev-libs/log4c/files/digest-log4c-1.0.61
-rw-r--r--dev-libs/log4c/log4c-1.0.6.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/log4c/ChangeLog b/dev-libs/log4c/ChangeLog
new file mode 100644
index 000000000000..39a8c0d9efd1
--- /dev/null
+++ b/dev-libs/log4c/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-libs/log4c
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.1 2002/05/03 01:32:35 mkennedy Exp $
+
+*log4c-1.0.6 (2 May 2002)
+
+ 2 May 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ log4c-1.0.6.ebuild, files/digest-log4c-1.0.6 :
+
+ New ebuild.
+
+ Log4c is a library of C for flexible logging to files, syslog and
+ other destinations. It is modeled after the Log for Java library
+ (http://jakarta.apache.org/log4j/), staying as close to their API as
+ is reasonable.
diff --git a/dev-libs/log4c/files/digest-log4c-1.0.6 b/dev-libs/log4c/files/digest-log4c-1.0.6
new file mode 100644
index 000000000000..6ee33c689912
--- /dev/null
+++ b/dev-libs/log4c/files/digest-log4c-1.0.6
@@ -0,0 +1 @@
+MD5 8423cf1b27ede6f80525750515b65419 log4c-1.0.6.tar.gz 238798
diff --git a/dev-libs/log4c/log4c-1.0.6.ebuild b/dev-libs/log4c/log4c-1.0.6.ebuild
new file mode 100644
index 000000000000..f3bfa2e0971c
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mkennedy@gentoo.org>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.0.6.ebuild,v 1.1 2002/05/03 01:32:35 mkennedy Exp $
+
+LICENSE="LGPL-2.1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations. It is modeled after the Log for Java library (http://jakarta.apache.org/log4j/), staying as close to their API as is reasonable."
+SRC_URI="http://prdownloads.sourceforge.net/log4c/${P}.tar.gz"
+HOMEPAGE="http://www.cimai.com/opensource/log4c/index.html"
+
+DEPEND="virtual/glibc
+ >=dev-libs/expat-1.95.2
+ >=app-doc/doxygen-1.2.15
+ >=media-gfx/graphviz-1.7.15-r2
+ >=app-text/tetex-1.0.7-r9"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/expat-1.95.2"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+
+ # temporary location for font generation (possibly requiring
+ # "texconfig font options varfonts" first)
+ export VARTEXFONTS=/tmp
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}