summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-25 17:02:33 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-25 17:02:33 +0000
commitd6882f703cf2d84288e763d6bf94bea1cb4f2a03 (patch)
tree35cbf5c010e009c52bc08e345d8450b194de59cb /dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch
parentold (diff)
downloadgentoo-2-d6882f703cf2d84288e763d6bf94bea1cb4f2a03.tar.gz
gentoo-2-d6882f703cf2d84288e763d6bf94bea1cb4f2a03.tar.bz2
gentoo-2-d6882f703cf2d84288e763d6bf94bea1cb4f2a03.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch')
-rw-r--r--dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch b/dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch
new file mode 100644
index 000000000000..b518f71834ad
--- /dev/null
+++ b/dev-libs/matrixssl/files/matrixssl-1.8.3-build.patch
@@ -0,0 +1,65 @@
+--- src/Makefile
++++ src/Makefile
+@@ -6,7 +6,7 @@
+ #
+
+ CC = gcc
+-STRIP = strip
++STRIP = true
+ AR = ar
+ RANLIB = ranlib
+ O = .o
+@@ -15,7 +15,7 @@
+ E =
+
+ LIBRARY = libmatrixssl$(SO)
+-STATIC = libmatrixsslstatic$(A)
++STATIC = libmatrixssl$(A)
+
+ OBJECTS = \
+ cipherSuite$(O) \
+@@ -50,7 +50,6 @@
+ STRIP = test
+ else
+ #DFLAGS = -Os
+-DFLAGS = -O3
+ endif
+
+ ifdef MATRIXSSL_PROFILE
+@@ -62,14 +61,14 @@
+ # Override variables for compilation on x86-64 (AMD64, Nacona, etc)
+ #
+ ifeq ($(shell uname -m),x86_64)
+-DFLAGS += -march=k8 -fPIC -DFP_64BIT -DTFM_X86_64 -DRDTSC
++DFLAGS += -DFP_64BIT -DTFM_X86_64 -DRDTSC
+ endif
+
+ #
+ # Compile options
+ #
+-SHARED = -shared
++SHARED = -shared -Wl,-soname,$@
+-CFLAGS = $(DFLAGS) -fPIC -DLINUX -I./
++CFLAGS += $(DFLAGS) -fPIC -DLINUX -I./
+ LDFLAGS += -lc -lpthread
+
+ #
+--- src/os/linux/linux.c
++++ src/os/linux/linux.c
+@@ -31,6 +31,8 @@
+ */
+ /******************************************************************************/
+ #ifdef LINUX
++#define _XOPEN_SOURCE 600
++#include <strings.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>
+@@ -40,7 +42,6 @@
+ #include "../osLayer.h"
+
+ #if defined(USE_RDTSCLL_TIME) || defined(RDTSC)
+-#include <asm/timex.h>
+ /*
+ As defined in asm/timex.h for x386:
+ */