summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-02-16 22:48:23 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-02-16 22:48:23 +0000
commitb38dcd1cffa1fa764c99f59e39cd5818d3fecb90 (patch)
tree2c3e08fda6b1cd01ebe8d2cf7b60912d2bdc6842 /dev-libs/openssl/openssl-0.9.7c-r1.ebuild
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-b38dcd1cffa1fa764c99f59e39cd5818d3fecb90.tar.gz
gentoo-2-b38dcd1cffa1fa764c99f59e39cd5818d3fecb90.tar.bz2
gentoo-2-b38dcd1cffa1fa764c99f59e39cd5818d3fecb90.zip
Fixed compilation of sparc32 target on sparc64
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.7c-r1.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.7c-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
index 418c79ef1b51..e1fb3fe82380 100644
--- a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.19 2004/02/09 23:02:20 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.20 2004/02/16 22:48:23 gustavoz Exp $
inherit eutils flag-o-matic
@@ -120,6 +120,10 @@ src_compile() {
elif [ "`uname -m`" = "parisc" -o "`uname -m`" = "parisc64" ]; then
./Configure linux-parisc --prefix=/usr --openssldir=/etc/ssl \
shared threads || die
+ # force sparcv8 on sparc32 profile
+ elif [ "$PROFILE_ARCH" = "sparc" ]; then
+ ./Configure linux-sparcv8 --prefix=/usr --openssldir=/etc/ssl \
+ shared threads || die
else
./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
fi
@@ -132,7 +136,8 @@ src_compile() {
test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
cd ${WORKDIR}/${OLD_096_P}
- if [ "$PROFILE_ARCH" = "sparc" -a "`uname -m`" = "sparc64" ]; then
+ # force sparcv8 on sparc32 profile
+ if [ "$PROFILE_ARCH" = "sparc" ]; then
SSH_TARGET="linux-sparcv8"
elif [ "`uname -m`" = "parisc" -o "`uname -m`" = "parisc64" ]; then
SSH_TARGET="linux-parisc"