summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2010-12-24 22:41:58 +0000
committerMatt Turner <mattst88@gentoo.org>2010-12-24 22:41:58 +0000
commit8d53a2d1190c3fd3f1bebee65c75cc56e830a275 (patch)
tree849ae1c357f960345630d35ba2e40a83dd3eda33 /dev-libs/popt
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-8d53a2d1190c3fd3f1bebee65c75cc56e830a275.tar.gz
gentoo-2-8d53a2d1190c3fd3f1bebee65c75cc56e830a275.tar.bz2
gentoo-2-8d53a2d1190c3fd3f1bebee65c75cc56e830a275.zip
Fix pkgconfigdir definition, bug 349558
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/popt')
-rw-r--r--dev-libs/popt/ChangeLog8
-rw-r--r--dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch12
-rw-r--r--dev-libs/popt/popt-1.16-r1.ebuild40
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/popt/ChangeLog b/dev-libs/popt/ChangeLog
index 956bcf399523..08395e9fb0ce 100644
--- a/dev-libs/popt/ChangeLog
+++ b/dev-libs/popt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/popt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.91 2010/10/03 13:18:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.92 2010/12/24 22:41:58 mattst88 Exp $
+
+*popt-1.16-r1 (24 Dec 2010)
+
+ 24 Dec 2010; Matt Turner <mattst88@gentoo.org> +popt-1.16-r1.ebuild,
+ +files/fix-popt-pkgconfig-libdir.patch:
+ Fix pkgconfigdir definition, bug 349558
03 Oct 2010; Raúl Porcel <armin76@gentoo.org> popt-1.16.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #324619
diff --git a/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch b/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch
new file mode 100644
index 000000000000..32e1bb353037
--- /dev/null
+++ b/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch
@@ -0,0 +1,12 @@
+diff -u popt-1.16.orig/Makefile.in popt-1.16/Makefile.in
+--- popt-1.16.orig/Makefile.in 2010-05-04 16:55:59.000000000 -0400
++++ popt-1.16/Makefile.in 2010-12-23 22:45:42.843131000 -0500
+@@ -370,7 +370,7 @@
+ libpopt_la_SOURCES = popt.c poptparse.c poptconfig.c popthelp.c poptint.c
+ libpopt_la_LDFLAGS = -no-undefined @LTLIBINTL@ @LTLIBICONV@ \
+ $(am__append_1)
+-pkgconfigdir = $(prefix)/lib/pkgconfig
++pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = popt.pc
+ man_MANS = popt.3
+ BUILT_SOURCES = popt.pc # popt.lcd
diff --git a/dev-libs/popt/popt-1.16-r1.ebuild b/dev-libs/popt/popt-1.16-r1.ebuild
new file mode 100644
index 000000000000..9799e339949a
--- /dev/null
+++ b/dev-libs/popt/popt-1.16-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.16-r1.ebuild,v 1.1 2010/12/24 22:41:58 mattst88 Exp $
+
+EAPI=3
+
+# For bug 349558, epatch
+inherit eutils
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # For bug 349558
+ epatch "${FILESDIR}"/fix-popt-pkgconfig-libdir.patch
+
+ sed -i \
+ -e 's:lt-test1:test1:' \
+ testit.sh || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README || die
+}