summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-15 12:15:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-15 12:15:57 +0000
commitfa9e6493935de4273f76d50cedf2b11b5807ae49 (patch)
treeda696003be1e9225b0b19ed81eb6ae816669edc3 /dev-libs/protobuf
parentPrevent people from doing silly things wrt #319807. (diff)
downloadgentoo-2-fa9e6493935de4273f76d50cedf2b11b5807ae49.tar.gz
gentoo-2-fa9e6493935de4273f76d50cedf2b11b5807ae49.tar.bz2
gentoo-2-fa9e6493935de4273f76d50cedf2b11b5807ae49.zip
Fix building with -Wl,--as-needed wrt #271509 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/ChangeLog6
-rw-r--r--dev-libs/protobuf/files/protobuf-2.3.0-asneeded.patch26
-rw-r--r--dev-libs/protobuf/protobuf-2.3.0.ebuild7
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index 804d3b4e32a1..a40bea14d1d0 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.18 2010/05/14 19:30:02 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.19 2010/05/15 12:15:57 ssuominen Exp $
+
+ 15 May 2010; Samuli Suominen <ssuominen@gentoo.org> protobuf-2.3.0.ebuild,
+ +files/protobuf-2.3.0-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #271509 by Kacper Kowalik.
14 May 2010; Joseph Jezak <josejx@gentoo.org> protobuf-2.3.0.ebuild:
Marked ~ppc/~ppc64 for bug #289287.
diff --git a/dev-libs/protobuf/files/protobuf-2.3.0-asneeded.patch b/dev-libs/protobuf/files/protobuf-2.3.0-asneeded.patch
new file mode 100644
index 000000000000..86c4b5976396
--- /dev/null
+++ b/dev-libs/protobuf/files/protobuf-2.3.0-asneeded.patch
@@ -0,0 +1,26 @@
+Fixing as-needed issues
+
+http://bugs.gentoo.org/show_bug.cgi?id=271509
+
+--- m4/acx_pthread.m4
++++ m4/acx_pthread.m4
+@@ -99,7 +99,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none pthread -Kthread -kthread lthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow:
+--- gtest/m4/acx_pthread.m4
++++ gtest/m4/acx_pthread.m4
+@@ -99,7 +99,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none pthread -Kthread -kthread lthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow:
diff --git a/dev-libs/protobuf/protobuf-2.3.0.ebuild b/dev-libs/protobuf/protobuf-2.3.0.ebuild
index 2c18969dcae3..6d6cb1a28d38 100644
--- a/dev-libs/protobuf/protobuf-2.3.0.ebuild
+++ b/dev-libs/protobuf/protobuf-2.3.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.3.0.ebuild,v 1.5 2010/05/14 19:30:02 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.3.0.ebuild,v 1.6 2010/05/15 12:15:57 ssuominen Exp $
EAPI="2"
JAVA_PKG_IUSE="source"
PYTHON_DEPEND="python? 2"
-inherit eutils distutils python java-pkg-opt-2 elisp-common
+inherit autotools eutils distutils python java-pkg-opt-2 elisp-common
DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
HOMEPAGE="http://code.google.com/p/protobuf/"
@@ -28,6 +28,9 @@ PYTHON_MODNAME="google/protobuf"
DISTUTILS_SRC_TEST="setup.py"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+
use python && {
python_convert_shebangs -r 2 .
distutils_src_prepare