summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-13 18:30:22 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-13 18:30:22 +0000
commit0d0aad90e934215f982899162c967dd2e14d6158 (patch)
tree94cd6456d99330bf274a02fc457667f3be4d53ad /dev-libs/pth
parentold (diff)
downloadgentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.tar.gz
gentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.tar.bz2
gentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.zip
Revbump for dev-libs/pth. Fixed parallel make install issue. Addressed small repoman warnings.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'dev-libs/pth')
-rw-r--r--dev-libs/pth/ChangeLog15
-rw-r--r--dev-libs/pth/files/pth-2.0.7-parallel-install.patch12
-rw-r--r--dev-libs/pth/pth-2.0.7-r1.ebuild4
-rw-r--r--dev-libs/pth/pth-2.0.7-r2.ebuild44
-rw-r--r--dev-libs/pth/pth-2.0.7.ebuild4
5 files changed, 73 insertions, 6 deletions
diff --git a/dev-libs/pth/ChangeLog b/dev-libs/pth/ChangeLog
index 3384d94c05aa..38aa8a7fefdd 100644
--- a/dev-libs/pth/ChangeLog
+++ b/dev-libs/pth/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-libs/pth
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.60 2008/01/15 00:05:10 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.61 2010/12/13 18:30:22 c1pher Exp $
+
+*pth-2.0.7-r2 (13 Dec 2010)
+
+ 13 Dec 2010; Dane Smith <c1pher@gentoo.org> +pth-2.0.7-r2.ebuild,
+ +files/pth-2.0.7-parallel-install.patch:
+ New patch pth-2.0.7-parallel-install.patch addresses the parallel install
+ problem starting in 2.0.7.
+ Revbump to -r2 applies patch and removes the need to emake -j1 for
+ install.
+ Also fixes the implicit RDEPEND="${DEPEND}" warning in repoman.
+ Fixed the headers for 2.0.7 ad 2.0.7-r1.
15 Jan 2008; Mike Frysinger <vapier@gentoo.org> pth-2.0.7-r1.ebuild:
Use `emake -j1` when installing rather than `make`.
diff --git a/dev-libs/pth/files/pth-2.0.7-parallel-install.patch b/dev-libs/pth/files/pth-2.0.7-parallel-install.patch
new file mode 100644
index 000000000000..7952cff5763c
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.7-parallel-install.patch
@@ -0,0 +1,12 @@
+--- Makefile.in 2010-12-13 12:59:07.000000000 -0500
++++ Makefile.new 2010-12-13 13:00:22.000000000 -0500
+@@ -215,7 +215,8 @@
+
+ # install the package
+ install: all-for-install
+- @$(MAKE) $(MKFLAGS) install-dirs install-pth @INSTALL_PTHREAD@
++ @$(MAKE) $(MKFLAGS) install-dirs
++ @$(MAKE) $(MKFLAGS) install-pth @INSTALL_PTHREAD@
+ @touch .done-install >/dev/null 2>&1 || $(TRUE)
+ @$(MAKE) $(MKFLAGS) what-next
+ install-dirs:
diff --git a/dev-libs/pth/pth-2.0.7-r1.ebuild b/dev-libs/pth/pth-2.0.7-r1.ebuild
index 4ab77ef7fbc3..9a7cfeee7b36 100644
--- a/dev-libs/pth/pth-2.0.7-r1.ebuild
+++ b/dev-libs/pth/pth-2.0.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r1.ebuild,v 1.2 2008/01/15 00:05:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r1.ebuild,v 1.3 2010/12/13 18:30:22 c1pher Exp $
inherit eutils fixheadtails libtool
diff --git a/dev-libs/pth/pth-2.0.7-r2.ebuild b/dev-libs/pth/pth-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..99d0a9be4d7a
--- /dev/null
+++ b/dev-libs/pth/pth-2.0.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r2.ebuild,v 1.1 2010/12/13 18:30:22 c1pher Exp $
+
+inherit eutils fixheadtails libtool
+
+DESCRIPTION="GNU Portable Threads"
+HOMEPAGE="http://www.gnu.org/software/pth/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-sigstack.patch
+ epatch "${FILESDIR}"/${PN}-2.0.7-parallel-install.patch
+
+ ht_fix_file aclocal.m4 configure
+
+ elibtoolize
+}
+
+src_compile() {
+ local conf
+ use debug && conf="${conf} --enable-debug" # have a bug --disable-debug and shared
+ econf ${conf} || die
+ emake || die
+}
+
+src_install() {
+ #Parallel install issuse fixed with parallel-install.patch.
+ #Submitted upstream on 12-13-2010.
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS ChangeLog NEWS README THANKS USERS || die
+}
diff --git a/dev-libs/pth/pth-2.0.7.ebuild b/dev-libs/pth/pth-2.0.7.ebuild
index 09936a873683..37a7c9792207 100644
--- a/dev-libs/pth/pth-2.0.7.ebuild
+++ b/dev-libs/pth/pth-2.0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7.ebuild,v 1.12 2008/01/14 14:17:02 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7.ebuild,v 1.13 2010/12/13 18:30:22 c1pher Exp $
inherit eutils fixheadtails libtool