summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-01-11 11:03:18 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-01-11 11:03:18 +0000
commitbb8a1e9700689d0dd2bb52753d7eeeb8a6b3c9dd (patch)
tree2f71ea693feb1942d50c0647060cbec2848c7616 /dev-libs/pth
parentRemove deprecated media-sound/esound support (diff)
downloadgentoo-2-bb8a1e9700689d0dd2bb52753d7eeeb8a6b3c9dd.tar.gz
gentoo-2-bb8a1e9700689d0dd2bb52753d7eeeb8a6b3c9dd.tar.bz2
gentoo-2-bb8a1e9700689d0dd2bb52753d7eeeb8a6b3c9dd.zip
Bump to eapi4 and make static libs optional.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/pth')
-rw-r--r--dev-libs/pth/ChangeLog7
-rw-r--r--dev-libs/pth/pth-2.0.7-r3.ebuild27
2 files changed, 19 insertions, 15 deletions
diff --git a/dev-libs/pth/ChangeLog b/dev-libs/pth/ChangeLog
index 1a65da650c78..346fbd7af58f 100644
--- a/dev-libs/pth/ChangeLog
+++ b/dev-libs/pth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/pth
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.69 2011/06/23 14:44:10 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.70 2012/01/11 11:03:18 scarabeus Exp $
+
+ 11 Jan 2012; Tomáš Chvátal <scarabeus@gentoo.org> pth-2.0.7-r3.ebuild:
+ Bump to eapi4 and make static libs optional.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -pth-2.0.7-r2.ebuild:
Remove old ebuilds. Requested by Arfrever
diff --git a/dev-libs/pth/pth-2.0.7-r3.ebuild b/dev-libs/pth/pth-2.0.7-r3.ebuild
index feb352d3cb6a..d830e5dbf516 100644
--- a/dev-libs/pth/pth-2.0.7-r3.ebuild
+++ b/dev-libs/pth/pth-2.0.7-r3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r3.ebuild,v 1.5 2011/05/21 19:57:38 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r3.ebuild,v 1.6 2012/01/11 11:03:18 scarabeus Exp $
+
+EAPI=4
inherit eutils fixheadtails libtool flag-o-matic
@@ -11,14 +13,14 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug static-libs"
DEPEND=""
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DOCS="ANNOUNCE AUTHORS ChangeLog NEWS README THANKS USERS"
+
+src_prepare() {
epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
epatch "${FILESDIR}"/${PN}-2.0.6-ldflags.patch
epatch "${FILESDIR}"/${PN}-2.0.6-sigstack.patch
@@ -30,19 +32,18 @@ src_unpack() {
elibtoolize
}
-src_compile() {
+src_configure() {
# bug 350815
( use arm || use sh ) && append-flags -U_FORTIFY_SOURCE
local conf
use debug && conf="${conf} --enable-debug" # have a bug --disable-debug and shared
- econf ${conf} || die
- emake || die
+ econf \
+ ${conf} \
+ $(use_enable static-libs static)
}
src_install() {
- #Parallel install issuse fixed with parallel-install.patch.
- #Submitted upstream on 12-13-2010.
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog NEWS README THANKS USERS || die
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
}