summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2010-04-03 13:41:01 +0000
committerThomas Anderson <tanderson@gentoo.org>2010-04-03 13:41:01 +0000
commitc8a69fedb20d2d23601a2105be87ea1f4d0b4002 (patch)
tree7140411b097eb559ed3399d96953e68ff99160dd /dev-libs/stfl
parentBumping to 1.10.3, fixing bug #312715 (diff)
downloadgentoo-2-c8a69fedb20d2d23601a2105be87ea1f4d0b4002.tar.gz
gentoo-2-c8a69fedb20d2d23601a2105be87ea1f4d0b4002.tar.bz2
gentoo-2-c8a69fedb20d2d23601a2105be87ea1f4d0b4002.zip
Add dev-libs/stfl-0.21, thanks to Tim Harder <radhermit@gmail.com> in bug #296735 for initial ebuild updates and patches.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/stfl')
-rw-r--r--dev-libs/stfl/ChangeLog11
-rw-r--r--dev-libs/stfl/files/stfl-0.21-python.patch39
-rw-r--r--dev-libs/stfl/stfl-0.21.ebuild85
3 files changed, 133 insertions, 2 deletions
diff --git a/dev-libs/stfl/ChangeLog b/dev-libs/stfl/ChangeLog
index 7c134f1bd853..0905c66f4d35 100644
--- a/dev-libs/stfl/ChangeLog
+++ b/dev-libs/stfl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/stfl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.23 2009/08/30 12:24:35 tanderson Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.24 2010/04/03 13:41:00 tanderson Exp $
+
+*stfl-0.21 (03 Apr 2010)
+
+ 03 Apr 2010; Thomas Anderson <tanderson@gentoo.org> +stfl-0.21.ebuild,
+ +files/stfl-0.21-python.patch:
+ Add dev-libs/stfl-0.21, thanks to Tim Harder <radhermit@gmail.com> in bug
+ #296735 for initial ebuild updates and patches.
30 Aug 2009; Thomas Anderson <tanderson@gentoo.org> stfl-0.19.ebuild:
stable amd64, bug 281352
diff --git a/dev-libs/stfl/files/stfl-0.21-python.patch b/dev-libs/stfl/files/stfl-0.21-python.patch
new file mode 100644
index 000000000000..dbec12b7a6a4
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.21-python.patch
@@ -0,0 +1,39 @@
+diff -ur stfl-0.21.orig/Makefile stfl-0.21/Makefile
+--- stfl-0.21.orig/Makefile 2009-06-19 10:30:52.000000000 -0700
++++ stfl-0.21/Makefile 2009-12-23 15:12:34.986593069 -0800
+@@ -46,7 +46,7 @@
+ rm -f widgets/*.o spl/mod_stfl.so spl/example.db
+ cd perl5 && perl Makefile.PL && make clean && rm -f Makefile.old
+ rm -f perl5/stfl_wrap.c perl5/stfl.pm perl5/build_ok
+- rm -f python/stfl.py python/stfl.pyc python/_stfl.so
++ rm -f python/stfl.py python/_stfl.so
+ rm -f python/stfl_wrap.c python/stfl_wrap.o
+ rm -f ruby/Makefile ruby/stfl_wrap.c ruby/stfl_wrap.o
+ rm -f ruby/stfl.so ruby/build_ok Makefile.deps_new
+diff -ur stfl-0.21.orig/python/Makefile.snippet stfl-0.21/python/Makefile.snippet
+--- stfl-0.21.orig/python/Makefile.snippet 2009-06-18 01:27:16.000000000 -0700
++++ stfl-0.21/python/Makefile.snippet 2009-12-23 15:14:54.237606055 -0800
+@@ -21,20 +21,17 @@
+ PYTHON_VERSION = $(shell python -V 2>&1 | cut -f2 -d' ' | cut -f1-2 -d'.')
+ PYTHON_SITEARCH = $(shell python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
+
+-all: python/_stfl.so python/stfl.py python/stfl.pyc
++all: python/_stfl.so python/stfl.py
+
+ install: install_python
+
+-python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i swig/*.i
++python/_stfl.so python/stfl.py: libstfl.a stfl.h python/stfl.i swig/*.i
+ cd python && swig -python -threads stfl.i
+ gcc -shared -pthread -fPIC python/stfl_wrap.c -I/usr/include/python$(PYTHON_VERSION) \
+ -I. libstfl.a -lncursesw -o python/_stfl.so
+- cd python && python -c 'import stfl'
+
+-install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
++install_python: python/_stfl.so python/stfl.py
+ mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+- cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+
diff --git a/dev-libs/stfl/stfl-0.21.ebuild b/dev-libs/stfl/stfl-0.21.ebuild
new file mode 100644
index 000000000000..5dc2af9e8fbb
--- /dev/null
+++ b/dev-libs/stfl/stfl-0.21.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.21.ebuild,v 1.1 2010/04/03 13:41:00 tanderson Exp $
+
+EAPI="2"
+inherit eutils multilib perl-module python
+
+DESCRIPTION="A library which implements a curses-based widget set for text terminals"
+HOMEPAGE="http://www.clifford.at/stfl/"
+SRC_URI="http://www.clifford.at/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="examples perl python ruby"
+
+COMMON_DEPEND="sys-libs/ncurses[unicode]
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )"
+
+DEPEND="${COMMON_DEPEND}
+ perl? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s!-Os -ggdb!!" \
+ -e "s!^\(all:.*\) example!\1!" \
+ Makefile
+
+ epatch "${FILESDIR}/${P}-python.patch"
+
+ if ! use perl; then
+ echo "FOUND_PERL5=0" >>Makefile.cfg
+ fi
+
+ if ! use ruby; then
+ echo "FOUND_RUBY=0" >>Makefile.cfg
+ fi
+
+ if ! use python; then
+ echo "FOUND_PYTHON=0" >>Makefile.cfg
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ PYTHON
+ emake prefix="/usr" DESTDIR="${D}" libdir="$(get_libdir)" install || die "make install failed"
+
+ dodoc README
+
+ local exdir="/usr/share/doc/${PF}/examples"
+ if use examples; then
+ insinto ${exdir}
+ doins example.{c,stfl}
+ insinto ${exdir}/python
+ doins python/example.py
+ if use perl; then
+ insinto ${exdir}/perl
+ doins perl5/example.pl
+ fi
+ if use ruby; then
+ insinto ${exdir}/ruby
+ doins ruby/example.rb
+ fi
+ fi
+
+ fixlocalpod
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize usr/$(get_libdir)/python$(python_get_version)/site-packages/stfl.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}