summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-04-25 17:06:03 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-04-25 17:06:03 +0000
commit158b7273c8498fbb94b1dc020f4eab898e52eedc (patch)
tree50fd9a6849f2b06f87ebffac1b10c0c931646350 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-158b7273c8498fbb94b1dc020f4eab898e52eedc.tar.gz
gentoo-2-158b7273c8498fbb94b1dc020f4eab898e52eedc.tar.bz2
gentoo-2-158b7273c8498fbb94b1dc020f4eab898e52eedc.zip
Version bump
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgcrypt/ChangeLog7
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 37890ae5a71f..5d9a1699e49e 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgcrypt
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.112 2008/02/13 10:56:01 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.113 2008/04/25 17:06:03 alonbl Exp $
+
+*libgcrypt-1.4.1 (25 Apr 2008)
+
+ 25 Apr 2008; Alon Bar-Lev <alonbl@gentoo.org> +libgcrypt-1.4.1.ebuild:
+ Version bump
13 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org> -libgcrypt-1.2.2-r1.ebuild:
Cleanup
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.1.ebuild
new file mode 100644
index 000000000000..5d8c7c995cb6
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.1.ebuild,v 1.1 2008/04/25 17:06:03 alonbl Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
+ !bindist? ( idea? ( mirror://gentoo/${PN}-1.4.0-idea.diff.bz2 ) )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls bindist idea"
+
+RDEPEND="nls? ( virtual/libintl )
+ >=dev-libs/libgpg-error-1.5"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use idea; then
+ if use bindist; then
+ elog "Skipping IDEA support to comply with binary distribution (bug #148907)."
+ else
+ ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
+ epatch "${WORKDIR}/${PN}-1.4.0-idea.diff"
+ AT_M4DIR="m4" eautoreconf
+ fi
+ fi
+}
+
+src_compile() {
+ # --disable-padlock-support for bug#201917
+ econf \
+ --disable-padlock-support \
+ --disable-dependency-tracking \
+ --with-pic \
+ --enable-noexecstack \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+}
+
+pkg_postinst() {
+ if use !bindist && use idea; then
+ ewarn "-----------------------------------------------------------------------------------"
+ ewarn "IDEA"
+ ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
+ ewarn "is distributed under the GPL in countries where it is permitted to do so"
+ ewarn "by law."
+ ewarn
+ ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
+ ewarn
+ ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
+ ewarn "to use it at no cost for 'non revenue generating data transfer between private"
+ ewarn "individuals'."
+ ewarn
+ ewarn "Countries where the patent applies are listed here"
+ ewarn "http://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm#Security"
+ ewarn "-----------------------------------------------------------------------------------"
+ fi
+}