summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-10 13:28:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-10 13:28:23 +0000
commit29998e18cebdb7c2e6bedadaba88168d252f58c0 (patch)
tree5daf3810b9c929e141000188e87881f910aa4769 /dev-libs
parentFix for #41399. (Manifest recommit) (diff)
downloadgentoo-2-29998e18cebdb7c2e6bedadaba88168d252f58c0.tar.gz
gentoo-2-29998e18cebdb7c2e6bedadaba88168d252f58c0.tar.bz2
gentoo-2-29998e18cebdb7c2e6bedadaba88168d252f58c0.zip
hppa stable
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/libxml2-2.6.7.ebuild8
-rw-r--r--dev-libs/libxslt/libxslt-1.1.4.ebuild22
2 files changed, 12 insertions, 18 deletions
diff --git a/dev-libs/libxml2/libxml2-2.6.7.ebuild b/dev-libs/libxml2/libxml2-2.6.7.ebuild
index b74604813744..642efd850298 100644
--- a/dev-libs/libxml2/libxml2-2.6.7.ebuild
+++ b/dev-libs/libxml2/libxml2-2.6.7.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.7.ebuild,v 1.1 2004/03/07 00:13:19 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.7.ebuild,v 1.2 2004/03/10 13:24:18 vapier Exp $
inherit libtool gnome.org flag-o-matic
DESCRIPTION="Version 2 of the library to manipulate XML files"
HOMEPAGE="http://www.xmlsoft.org/"
-LICENSE="MIT"
-IUSE="python readline ipv6"
+LICENSE="MIT"
SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~ppc64 ~mips"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa ~amd64 ~ia64 ~ppc64 ~mips"
+IUSE="python readline ipv6"
DEPEND="sys-libs/zlib
python? ( dev-lang/python )
diff --git a/dev-libs/libxslt/libxslt-1.1.4.ebuild b/dev-libs/libxslt/libxslt-1.1.4.ebuild
index 63d070883db1..586e8ce9ce32 100644
--- a/dev-libs/libxslt/libxslt-1.1.4.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.4.ebuild
@@ -1,32 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.4.ebuild,v 1.2 2004/03/07 00:49:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.4.ebuild,v 1.3 2004/03/10 13:28:23 vapier Exp $
inherit libtool gnome.org
-[ -n "`use python`" ] && inherit python
+use python && inherit python
-IUSE="python"
DESCRIPTION="XSLT libraries and tools"
HOMEPAGE="http://www.xmlsoft.org/"
-SLOT="0"
+
LICENSE="MIT"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~s390"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa ~amd64 ~ia64 ~s390"
+IUSE="python"
DEPEND=">=dev-libs/libxml2-2.6.5
python? ( dev-lang/python )"
src_compile() {
-
elibtoolize
-
- econf $(use_with python) || die "configure failed"
-
+ econf `use_with python` || die "configure failed"
emake || die "make failed"
-
}
src_install() {
-
make DESTDIR=${D} \
DOCS_DIR=/usr/share/doc/${PF}/python \
EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
@@ -35,7 +31,5 @@ src_install() {
EXAMPLES_DIR=/usr/share/doc/${PF}/example \
TARGET_DIR=/usr/share/doc/${PF}/html \
install || die "install failed"
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
-
+ dodoc AUTHORS ChangeLog README NEWS TODO
}