summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-18 20:08:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-18 20:08:44 +0000
commit4ab0f9ac3aaf8bee881e2290d84a9954094587b3 (patch)
tree26d1d6445f061dd83bc55f461fe11f90128ebe04 /dev-libs
parentStable for amd64, wrt bug #410611 (diff)
downloadgentoo-2-4ab0f9ac3aaf8bee881e2290d84a9954094587b3.tar.gz
gentoo-2-4ab0f9ac3aaf8bee881e2290d84a9954094587b3.tar.bz2
gentoo-2-4ab0f9ac3aaf8bee881e2290d84a9954094587b3.zip
Install expatu.pc and expatw.pc pkg-config files with USE="unicode"
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/ChangeLog7
-rw-r--r--dev-libs/expat/expat-2.1.0-r1.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index df6ed1d1493c..406c33cca4dc 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/expat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.133 2012/04/16 02:29:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.134 2012/04/18 20:08:44 ssuominen Exp $
+
+*expat-2.1.0-r1 (18 Apr 2012)
+
+ 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +expat-2.1.0-r1.ebuild:
+ Install expatu.pc and expatw.pc pkg-config files with USE="unicode"
16 Apr 2012; Jeroen Roovers <jer@gentoo.org> expat-2.1.0.ebuild:
Stable for HPPA (bug #412089).
diff --git a/dev-libs/expat/expat-2.1.0-r1.ebuild b/dev-libs/expat/expat-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..0cffa347034c
--- /dev/null
+++ b/dev-libs/expat/expat-2.1.0-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.1.0-r1.ebuild,v 1.1 2012/04/18 20:08:44 ssuominen Exp $
+
+EAPI=4
+inherit eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="elibc_FreeBSD examples static-libs unicode"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+
+ mkdir "${S}"-build{,u,w} || die
+}
+
+src_configure() {
+ local myconf="$(use_enable static-libs static)"
+
+ pushd "${S}"-build >/dev/null
+ ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ CFLAGS="${CFLAGS} -fshort-wchar" CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ pushd "${S}"-build >/dev/null
+ emake
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake buildlib LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake buildlib LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ dodoc Changes README
+ dohtml doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ pushd "${S}"-build >/dev/null
+ emake install DESTDIR="${D}"
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
+ popd >/dev/null
+
+ pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
+ cp expat.pc expatu.pc
+ sed -i -e '/^Libs/s:-lexpat:&u:' expatu.pc || die
+ cp expat.pc expatw.pc
+ sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
+ popd >/dev/null
+ fi
+
+ rm -f "${ED}"usr/lib*/libexpat{,u,w}.la
+
+ # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
+ # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
+ use elibc_FreeBSD && gen_usr_ldscript -a expat
+}