summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-01 18:20:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-01 18:20:22 +0000
commit59db98bd903bc899f815d6936f186367d0ed6e9e (patch)
tree4819ac1627bf4e1e7318848dad4def3a2dfaa5dc /dev-libs
parentVersion bump; 1.8.0 is a big rewrite and thus is currently masked. S/Key supp... (diff)
downloadgentoo-2-59db98bd903bc899f815d6936f186367d0ed6e9e.tar.gz
gentoo-2-59db98bd903bc899f815d6936f186367d0ed6e9e.tar.bz2
gentoo-2-59db98bd903bc899f815d6936f186367d0ed6e9e.zip
Version bump.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libofx/ChangeLog9
-rw-r--r--dev-libs/libofx/libofx-0.9.2.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-libs/libofx/ChangeLog b/dev-libs/libofx/ChangeLog
index e5160006b5bf..3618d297a4e4 100644
--- a/dev-libs/libofx/ChangeLog
+++ b/dev-libs/libofx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libofx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.54 2010/01/19 14:35:43 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.55 2011/03/01 18:20:22 ssuominen Exp $
+
+*libofx-0.9.2 (01 Mar 2011)
+
+ 01 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +libofx-0.9.2.ebuild:
+ Version bump.
19 Jan 2010; Brent Baude <ranger@gentoo.org> libofx-0.9.1.ebuild:
Marking libofx-0.9.1 ppc64 for bug 299533
diff --git a/dev-libs/libofx/libofx-0.9.2.ebuild b/dev-libs/libofx/libofx-0.9.2.ebuild
new file mode 100644
index 000000000000..7e886e20c6bc
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.9.2.ebuild,v 1.1 2011/03/01 18:20:22 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A library to support the Open Financial eXchange XML format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=app-text/opensp-1.5
+ dev-cpp/libxmlpp:0
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Be sure DTD gets installed in correct path after redefining docdir in install
+ sed -i \
+ -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
+ dtd/Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+ find "${D}" -name '*.la' -exec rm -f {} +
+}