summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-29 15:50:29 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-29 15:50:29 +0000
commit96da8414e8c7f74018e2244a728c8fc96a89608c (patch)
treed11371c2c03e0dce20a66db0e3b1bb4948671672 /dev-libs
parentInitial ebuild. (Manifest recommit) (diff)
downloadgentoo-2-96da8414e8c7f74018e2244a728c8fc96a89608c.tar.gz
gentoo-2-96da8414e8c7f74018e2244a728c8fc96a89608c.tar.bz2
gentoo-2-96da8414e8c7f74018e2244a728c8fc96a89608c.zip
fix build on alpha to use correct CPU setting
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ffcall/ffcall-1.8d.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-libs/ffcall/ffcall-1.8d.ebuild b/dev-libs/ffcall/ffcall-1.8d.ebuild
index 09d6d5a4898b..9b1d5017935a 100644
--- a/dev-libs/ffcall/ffcall-1.8d.ebuild
+++ b/dev-libs/ffcall/ffcall-1.8d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.10 2004/01/29 15:13:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.11 2004/01/29 15:50:29 agriffis Exp $
DESCRIPTION="foreign function call libraries"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
@@ -16,8 +16,7 @@ KEYWORDS="x86 sparc ~hppa ~alpha"
DEPEND="virtual/glibc"
-src_unpack()
-{
+src_unpack() {
unpack ${A}
#Fix hppa asm
use hppa && (cd ${S}; epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz)
@@ -25,8 +24,14 @@ src_unpack()
}
src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ $ARCH == alpha ]] && cpu_setting='CPU=alpha'
+
econf || die "./configure failed"
- make || die
+ make ${cpu_setting} || die
}
src_install () {