summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-16 05:17:40 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-16 05:17:40 +0000
commita3e6762f6c74e9c9fd0807fdd3d2f69cf65aa382 (patch)
tree027e11b1a7553cd145515dea64b011efb8aac0e2 /dev-libs
parentScrub CFLAGS from configure. (diff)
downloadgentoo-2-a3e6762f6c74e9c9fd0807fdd3d2f69cf65aa382.tar.gz
gentoo-2-a3e6762f6c74e9c9fd0807fdd3d2f69cf65aa382.tar.bz2
gentoo-2-a3e6762f6c74e9c9fd0807fdd3d2f69cf65aa382.zip
Version bump.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/elfutils/ChangeLog8
-rw-r--r--dev-libs/elfutils/elfutils-0.120.ebuild60
-rw-r--r--dev-libs/elfutils/files/digest-elfutils-0.1206
-rw-r--r--dev-libs/elfutils/files/elfutils-0.120-mkinstalldirs.patch22
4 files changed, 95 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 14c7a04db578..773caedd4bd4 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.74 2006/01/13 08:40:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.75 2006/04/16 05:17:39 vapier Exp $
+
+*elfutils-0.120 (16 Apr 2006)
+
+ 16 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/elfutils-0.120-mkinstalldirs.patch, +elfutils-0.120.ebuild:
+ Version bump.
13 Jan 2006; Mike Frysinger <vapier@gentoo.org> elfutils-0.108.ebuild,
elfutils-0.108-r1.ebuild, elfutils-0.118.ebuild:
diff --git a/dev-libs/elfutils/elfutils-0.120.ebuild b/dev-libs/elfutils/elfutils-0.120.ebuild
new file mode 100644
index 000000000000..932b5918d780
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.120.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.120.ebuild,v 1.1 2006/04/16 05:17:40 vapier Exp $
+
+inherit eutils autotools
+
+PVER="1.0"
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://people.redhat.com/drepper/"
+SRC_URI="ftp://sources.redhat.com/pub/systemtap/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
+
+LICENSE="OpenSoftware"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.3.2 )
+ sys-devel/gettext
+ sys-devel/autoconf
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-3.3.3
+ !dev-libs/libelf"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${WORKDIR}"/patch/*.patch
+ epatch "${FILESDIR}"/${PN}-0.118-libelf-link.patch
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.118-no-nested-functions.patch #116968
+ epatch "${FILESDIR}"/${PN}-0.120-mkinstalldirs.patch
+
+ eautoreconf
+
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+}
+
+src_compile() {
+ econf \
+ --program-prefix="eu-" \
+ --enable-shared \
+ || die "./configure failed"
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ make check || die "test failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}
diff --git a/dev-libs/elfutils/files/digest-elfutils-0.120 b/dev-libs/elfutils/files/digest-elfutils-0.120
new file mode 100644
index 000000000000..f796fcdeea56
--- /dev/null
+++ b/dev-libs/elfutils/files/digest-elfutils-0.120
@@ -0,0 +1,6 @@
+MD5 ccdd17f58c0c6feb35c9aff0b1217650 elfutils-0.120-patches-1.0.tar.bz2 16322
+RMD160 979160ef30a7d3d2bfc8bce20143b8663c62e3d0 elfutils-0.120-patches-1.0.tar.bz2 16322
+SHA256 527501e03b1267bd2e9f0283319db120d9f15324bd9f7820d24624a323ddf136 elfutils-0.120-patches-1.0.tar.bz2 16322
+MD5 3f757d85af891904892b4a6dc3f9e14c elfutils-0.120.tar.gz 1126669
+RMD160 9c9ad5f23092bb812a5cb6649005bb04b0226ea8 elfutils-0.120.tar.gz 1126669
+SHA256 0e868eb7468e639a95c1d5260bd0313cd30e578f308e0abf990a9519c2a304e7 elfutils-0.120.tar.gz 1126669
diff --git a/dev-libs/elfutils/files/elfutils-0.120-mkinstalldirs.patch b/dev-libs/elfutils/files/elfutils-0.120-mkinstalldirs.patch
new file mode 100644
index 000000000000..1af1b990182c
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.120-mkinstalldirs.patch
@@ -0,0 +1,22 @@
+--- libelf-po/Makefile.in.in
++++ libelf-po/Makefile.in.in
+@@ -28,7 +28,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -28,7 +28,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@