summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-06-15 11:43:24 +0000
committerMichał Górny <mgorny@gentoo.org>2015-06-15 11:43:24 +0000
commitac62d69ee0022971f6921ab36ac6eeb0803921ee (patch)
tree3b0ebc895c82d8f49e131e8be5163581631f6e09 /dev-libs
parentSync live ebuild with newest ~arch version. (diff)
downloadgentoo-2-ac62d69ee0022971f6921ab36ac6eeb0803921ee.tar.gz
gentoo-2-ac62d69ee0022971f6921ab36ac6eeb0803921ee.tar.bz2
gentoo-2-ac62d69ee0022971f6921ab36ac6eeb0803921ee.zip
Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/141 by jbergstroem.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libuv/ChangeLog8
-rw-r--r--dev-libs/libuv/libuv-1.6.1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index c1509e4aa224..e0f5230a8277 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libuv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.37 2015/05/18 15:43:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.38 2015/06/15 11:43:24 mgorny Exp $
+
+*libuv-1.6.1 (15 Jun 2015)
+
+ 15 Jun 2015; Michał Górny <mgorny@gentoo.org> +libuv-1.6.1.ebuild:
+ Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/141
+ by jbergstroem.
*libuv-1.5.0 (18 May 2015)
diff --git a/dev-libs/libuv/libuv-1.6.1.ebuild b/dev-libs/libuv/libuv-1.6.1.ebuild
new file mode 100644
index 000000000000..51e37a44a40f
--- /dev/null
+++ b/dev-libs/libuv/libuv-1.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-1.6.1.ebuild,v 1.1 2015/06/15 11:43:24 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils eutils multilib multilib-minimal
+
+DESCRIPTION="Cross-platform asychronous I/O"
+HOMEPAGE="https://github.com/libuv/libuv"
+SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ cc_cv_cflags__g=no
+ $(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
+}
+
+multilib_src_test() {
+ mkdir test || die
+ cp -pPR "${S}"/test/fixtures test/fixtures || die
+ default
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}