summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-16 03:24:01 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-16 03:24:01 +0000
commitc36eff220748c059f57d733a936eebd425caee9a (patch)
tree02ccf1f16bd78e949ee1be065f0bcff758fcecdf /dev-libs
parentStable for HPPA (bug #412089). (diff)
downloadgentoo-2-c36eff220748c059f57d733a936eebd425caee9a.tar.gz
gentoo-2-c36eff220748c059f57d733a936eebd425caee9a.tar.bz2
gentoo-2-c36eff220748c059f57d733a936eebd425caee9a.zip
Fix building on systems with gnustep-base installed (bug #411981, thanks to Carlos Konstanski et al. for reporting).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/files/glib-2.32.1-gnustep-not-cocoa.patch29
-rw-r--r--dev-libs/glib/glib-2.32.1.ebuild5
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 532e852bbb77..d1da0ce57c6d 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.513 2012/04/14 23:23:18 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.514 2012/04/16 03:24:01 tetromino Exp $
+
+ 16 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> glib-2.32.1.ebuild,
+ +files/glib-2.32.1-gnustep-not-cocoa.patch:
+ Fix building on systems with gnustep-base installed (bug #411981, thanks to
+ Carlos Konstanski et al. for reporting).
14 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> glib-2.32.0.ebuild,
glib-2.32.1.ebuild, +files/glib-2.32.1-fix-libelf-check.patch:
diff --git a/dev-libs/glib/files/glib-2.32.1-gnustep-not-cocoa.patch b/dev-libs/glib/files/glib-2.32.1-gnustep-not-cocoa.patch
new file mode 100644
index 000000000000..56014a9e3421
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.32.1-gnustep-not-cocoa.patch
@@ -0,0 +1,29 @@
+From 2d59182bfc3a799c140090c83db22a275aa858a0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 15 Apr 2012 22:57:25 -0400
+Subject: [PATCH] Do not detect GNUstep as Cocoa
+
+GNUstep also installs Foundation/Foundation.h
+
+https://bugzilla.gnome.org/show_bug.cgi?id=674172
+---
+ configure.ac | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 825d42d..2ae07f1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -179,6 +179,9 @@ glib_have_cocoa=no
+ AC_MSG_CHECKING([for Mac OS X Cocoa support])
+ AC_TRY_CPP([
+ #include <Foundation/Foundation.h>
++#ifdef GNUSTEP_BASE_VERSION
++#error "Detected GNUstep, not Cocoa"
++#endif
+ ], glib_have_cocoa=yes)
+
+ AC_MSG_RESULT([$glib_have_cocoa])
+--
+1.7.8.5
+
diff --git a/dev-libs/glib/glib-2.32.1.ebuild b/dev-libs/glib/glib-2.32.1.ebuild
index 992598e61a97..9e0e5675a876 100644
--- a/dev-libs/glib/glib-2.32.1.ebuild
+++ b/dev-libs/glib/glib-2.32.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.4 2012/04/14 23:23:18 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.5 2012/04/16 03:24:01 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
@@ -115,6 +115,9 @@ src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=673132
epatch "${FILESDIR}/${PN}-2.32.1-fix-libelf-check.patch"
+ # bug #411981, https://bugzilla.gnome.org/show_bug.cgi?id=674172
+ epatch "${FILESDIR}/${PN}-2.32.1-gnustep-not-cocoa.patch"
+
# disable pyc compiling
use test && python_clean_py-compile_files