summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-12-14 12:34:46 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-12-14 12:34:46 +0000
commitaba9ec607a7ca6206c89d93211c64c4cd26df4d8 (patch)
tree0df048be97ff8a8e0def8e34d3ea526699209f05 /dev-lisp/asdf
parentMasked stuff from the lisp overlay for testing (diff)
downloadgentoo-2-aba9ec607a7ca6206c89d93211c64c4cd26df4d8.tar.gz
gentoo-2-aba9ec607a7ca6206c89d93211c64c4cd26df4d8.tar.bz2
gentoo-2-aba9ec607a7ca6206c89d93211c64c4cd26df4d8.zip
From the lisp overlay, version bumped
(Portage version: 2.2.0_alpha148/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-lisp/asdf')
-rw-r--r--dev-lisp/asdf/ChangeLog7
-rw-r--r--dev-lisp/asdf/asdf-2.26.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/dev-lisp/asdf/ChangeLog b/dev-lisp/asdf/ChangeLog
index e7f0d1437666..9794f01e9390 100644
--- a/dev-lisp/asdf/ChangeLog
+++ b/dev-lisp/asdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/asdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.4 2012/10/10 10:30:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.5 2012/12/14 12:34:46 grozin Exp $
+
+*asdf-2.26 (14 Dec 2012)
+
+ 14 Dec 2012; Andrey Grozin <grozin@gentoo.org> +asdf-2.26.ebuild:
+ From the lisp overlay, version bumped
10 Oct 2012; Anthony G. Basile <blueness@gentoo.org> asdf-1.89.ebuild:
stable ppc ppc64, bug #436846
diff --git a/dev-lisp/asdf/asdf-2.26.ebuild b/dev-lisp/asdf/asdf-2.26.ebuild
new file mode 100644
index 000000000000..6c7d8d5c8e32
--- /dev/null
+++ b/dev-lisp/asdf/asdf-2.26.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/asdf-2.26.ebuild,v 1.1 2012/12/14 12:34:46 grozin Exp $
+
+EAPI=4
+
+DESCRIPTION="ASDF is Another System Definition Facility for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/asdf/"
+SRC_URI="http://common-lisp.net/project/${PN}/archives/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}
+ !dev-lisp/asdf-binary-locations"
+
+S="${WORKDIR}/${PN}"
+
+CLSOURCEROOT="${ROOT%/}"/usr/share/common-lisp/source
+CLSYSTEMROOT="${ROOT%/}"/usr/share/common-lisp/systems
+CLPACKAGE="${PN}"
+
+absolute-path-p() {
+ [[ $# -eq 1 ]] || die "${FUNCNAME[0]} must receive one argument"
+ [[ ${1} == /* ]]
+}
+
+common-lisp-install-one-source() {
+ [[ $# -eq 3 ]] || die "${FUNCNAME[0]} must receive exactly three arguments"
+
+ local fpredicate=${1}
+ local source=${2}
+ local target="${CLSOURCEROOT}/${CLPACKAGE}/${3}"
+
+ if absolute-path-p "${source}" ; then
+ die "Cannot install files with absolute path: ${source}"
+ fi
+
+ if ${fpredicate} "${source}" ; then
+ insinto "${target}"
+ doins "${source}"
+ fi
+}
+
+lisp-file-p() {
+ [[ $# -eq 1 ]] || die "${FUNCNAME[0]} must receive one argument"
+
+ [[ ${1} =~ \.(lisp|lsp|cl)$ ]]
+}
+
+common-lisp-get-fpredicate() {
+ [[ $# -eq 1 ]] || die "${FUNCNAME[0]} must receive one argument"
+
+ local ftype=${1}
+ case ${ftype} in
+ "lisp") echo "lisp-file-p" ;;
+ "all" ) echo "true" ;;
+ * ) die "Unknown filetype specifier ${ftype}" ;;
+ esac
+}
+
+common-lisp-install-sources() {
+ local ftype="lisp"
+ if [[ ${1} == "-t" ]] ; then
+ ftype=${2}
+ shift ; shift
+ fi
+
+ [[ $# -ge 1 ]] || die "${FUNCNAME[0]} must receive one non-option argument"
+
+ local fpredicate=$(common-lisp-get-fpredicate "${ftype}")
+
+ for path in "${@}" ; do
+ if [[ -f ${path} ]] ; then
+ common-lisp-install-one-source ${fpredicate} "${path}" "$(dirname "${path}")"
+ elif [[ -d ${path} ]] ; then
+ common-lisp-install-sources -t ${ftype} $(find "${path}" -type f)
+ else
+ die "${path} it neither a regular file nor a directory"
+ fi
+ done
+}
+
+common-lisp-install-one-asdf() {
+ [[ $# != 1 ]] && die "${FUNCNAME[0]} must receive exactly one argument"
+
+ # the suffix «.asd» is optional
+ local source=${1/.asd}.asd
+ common-lisp-install-one-source true "${source}" "$(dirname "${source}")"
+ local target="${CLSOURCEROOT%/}/${CLPACKAGE}/${source}"
+ dosym "${target}" "${CLSYSTEMROOT%/}/$(basename ${target})"
+}
+
+common-lisp-install-asdf() {
+ dodir "${CLSYSTEMROOT}"
+
+ [[ $# = 0 ]] && set - ${CLSYSTEMS}
+ [[ $# = 0 ]] && set - $(find . -type f -name \*.asd)
+ for sys in "${@}" ; do
+ common-lisp-install-one-asdf ${sys}
+ done
+}
+
+src_install() {
+ common-lisp-install-sources {asdf,asdf-ecl,wild-modules}.lisp
+ common-lisp-install-asdf asdf.asd
+ dodoc README
+}