summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 22:22:54 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 22:22:54 +0000
commita242d23d87d78298643837fd29e81ac7cdaa3a23 (patch)
tree857fc1f15d7aebac60fc19774adb0947625fb741 /dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild
parentAdd common pam.d stuff. Related to #79240. (diff)
downloadgentoo-2-a242d23d87d78298643837fd29e81ac7cdaa3a23.tar.gz
gentoo-2-a242d23d87d78298643837fd29e81ac7cdaa3a23.tar.bz2
gentoo-2-a242d23d87d78298643837fd29e81ac7cdaa3a23.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild')
-rw-r--r--dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild b/dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild
new file mode 100644
index 000000000000..34687fd01d0f
--- /dev/null
+++ b/dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-periodic-table/cl-periodic-table-1.0.ebuild,v 1.1 2005/02/10 22:22:15 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Common Lisp representation of the Periodic Table of the Elements"
+HOMEPAGE="http://common-lisp.net/project/chemboy/
+ http://www.cliki.net/periodic-table"
+SRC_URI="mirror://gentoo/periodic-table-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=periodic-table
+
+S=${WORKDIR}/periodic-table-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc README
+}