summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
commitf0499138e7aa5e43bdb88278d6bef3650c46e229 (patch)
treeb29a74bee14985fc7da4a51785f23c0829b3b5d5 /dev-lisp/cl-png
parentinitial common lisp import (diff)
downloadgentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.gz
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.bz2
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-png')
-rw-r--r--dev-lisp/cl-png/ChangeLog8
-rw-r--r--dev-lisp/cl-png/Manifest5
-rw-r--r--dev-lisp/cl-png/cl-png-0.2.ebuild27
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.21
-rw-r--r--dev-lisp/cl-png/files/png.asd15
5 files changed, 53 insertions, 3 deletions
diff --git a/dev-lisp/cl-png/ChangeLog b/dev-lisp/cl-png/ChangeLog
new file mode 100644
index 000000000000..8bfa70c88dad
--- /dev/null
+++ b/dev-lisp/cl-png/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-png
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-png-0.2 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-png/Manifest b/dev-lisp/cl-png/Manifest
index cb47e7fd8a95..d6b203bb3ab5 100644
--- a/dev-lisp/cl-png/Manifest
+++ b/dev-lisp/cl-png/Manifest
@@ -1,5 +1,4 @@
-MD5 e1e459cbca3395cac28559fef7c9629f ChangeLog 314
-MD5 8150edfbd6f59feca73542d2e3286d29 cl-png-0.2.ebuild 668
-MD5 992cbf0615095a60a3d7d798a53f8602 cl-png-0.2.ebuild~ 789
+MD5 9c04abc76c2a7a504b18505a5425b28b ChangeLog 313
+MD5 130fb9c3ccab3ba85931091048687c33 cl-png-0.2.ebuild 784
MD5 e290aa9540cabbe9b5a89dd298083758 files/png.asd 384
MD5 9cc53124d98aa4b18abfb63e43635efe files/digest-cl-png-0.2 58
diff --git a/dev-lisp/cl-png/cl-png-0.2.ebuild b/dev-lisp/cl-png/cl-png-0.2.ebuild
new file mode 100644
index 000000000000..c64d703dddc8
--- /dev/null
+++ b/dev-lisp/cl-png/cl-png-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.2.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to read and write PNG image files"
+HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
+ http://www.cliki.net/PNG
+ http://packages.debian.org/unstable/devel/cl-png.html"
+SRC_URI="http://www.pvv.ntnu.no/~musum/lisp/code/png-${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=png
+
+S=${WORKDIR}/png-${PV}
+
+src_install() {
+ common-lisp-install *.cl ${FILESDIR}/png.asd
+ common-lisp-system-symlink
+ dodoc COPYING README
+}
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.2 b/dev-lisp/cl-png/files/digest-cl-png-0.2
new file mode 100644
index 000000000000..01b73c3e0eec
--- /dev/null
+++ b/dev-lisp/cl-png/files/digest-cl-png-0.2
@@ -0,0 +1 @@
+MD5 63130e77c737fc821d38b2beba3787b2 png-0.2.tar.gz 29424
diff --git a/dev-lisp/cl-png/files/png.asd b/dev-lisp/cl-png/files/png.asd
new file mode 100644
index 000000000000..b0fa65a6d72a
--- /dev/null
+++ b/dev-lisp/cl-png/files/png.asd
@@ -0,0 +1,15 @@
+;;;; -*- Mode: Lisp; Package: ASDF; -*-
+
+(in-package :asdf)
+
+(defsystem :png
+ :perform (load-op :after (op png)
+ (pushnew :png cl:*features*))
+ :components ((:file "zlib")
+ (:file "png-pkg"
+ :depends-on ("zlib"))
+ (:file "png"
+ :depends-on ("png-pkg" "zlib"))))
+
+(defmethod source-file-type ((c cl-source-file) (s (eql (find-system :png))))
+ "cl")