summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
commit81b947883609f274574d41292eed907b71537ff6 (patch)
tree15e292d44046ac9cf43ded04a989c7389fb49010 /dev-lisp/cl-rsm-string
parentdev-lisp/cl-rsm-gen-prog (diff)
downloadgentoo-2-81b947883609f274574d41292eed907b71537ff6.tar.gz
gentoo-2-81b947883609f274574d41292eed907b71537ff6.tar.bz2
gentoo-2-81b947883609f274574d41292eed907b71537ff6.zip
boo-ya ka-sha!
Diffstat (limited to 'dev-lisp/cl-rsm-string')
-rw-r--r--dev-lisp/cl-rsm-string/ChangeLog6
-rw-r--r--dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild9
-rw-r--r--dev-lisp/cl-rsm-string/files/1.3-ftype-gentoo.patch27
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-lisp/cl-rsm-string/ChangeLog b/dev-lisp/cl-rsm-string/ChangeLog
index c2d9a68a1172..f956e284dbea 100644
--- a/dev-lisp/cl-rsm-string/ChangeLog
+++ b/dev-lisp/cl-rsm-string/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-rsm-string
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-string/ChangeLog,v 1.3 2004/06/24 23:54:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-string/ChangeLog,v 1.4 2004/08/07 05:22:07 mkennedy Exp $
+
+ 06 Aug 2004; <mkennedy@gentoo.org> +files/1.3-ftype-gentoo.patch,
+ cl-rsm-string-1.3.ebuild:
+ Resolves build error due to invalid ftype declaimations
*cl-rsm-string-1.3 (12 Feb 2004)
diff --git a/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild b/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild
index d0606a7036c0..1710025a1321 100644
--- a/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild
+++ b/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild,v 1.3 2004/07/14 16:07:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-string/cl-rsm-string-1.3.ebuild,v 1.4 2004/08/07 05:22:07 mkennedy Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="R. Scott McIntire's Common Lisp String Library"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-string.html"
@@ -16,6 +16,11 @@ DEPEND="dev-lisp/common-lisp-controller
CLPACKAGE=rsm-string
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-ftype-gentoo.patch
+}
+
src_install() {
common-lisp-install *.lisp *.asd
common-lisp-system-symlink
diff --git a/dev-lisp/cl-rsm-string/files/1.3-ftype-gentoo.patch b/dev-lisp/cl-rsm-string/files/1.3-ftype-gentoo.patch
new file mode 100644
index 000000000000..aae3b62e1e79
--- /dev/null
+++ b/dev-lisp/cl-rsm-string/files/1.3-ftype-gentoo.patch
@@ -0,0 +1,27 @@
+Common subdirectories: cl-rsm-string-1.3.orig/debian and cl-rsm-string-1.3/debian
+Only in cl-rsm-string-1.3: package.x86f
+Only in cl-rsm-string-1.3: semantic.cache
+diff -u cl-rsm-string-1.3.orig/string.lisp cl-rsm-string-1.3/string.lisp
+--- cl-rsm-string-1.3.orig/string.lisp 2003-10-22 21:35:29.000000000 -0500
++++ cl-rsm-string-1.3/string.lisp 2004-08-06 23:02:18.627475008 -0500
+@@ -75,8 +75,7 @@
+ (concatenate 'string s1 join-string s2)) str-list))))
+
+
+-(declaim (ftype (function ((list string) (list string)
+- &key function) list)
++(declaim (ftype (function ((or list string) (or list string) &key (:function function)) list)
+ contains))
+
+ (defun contains (str-list elem-list &key (contain-meaning #'some))
+@@ -92,9 +91,6 @@
+ collect str))
+
+
+-(declaim (ftype (function (list string &key (:unique t)) list)
+- does-not-contain))
+-
+ (defun does-not-contain (str-list str-elems &key (unique nil))
+ "Return a list of strings from the string list, <str-list>, that do not
+ contain any of the strings from the list of strings <str-elems.> If unique is
+Only in cl-rsm-string-1.3: string.lisp~