summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-26 20:23:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-26 20:23:32 +0000
commit329b095530846ea1b97bc142d5fad8d97e88ec10 (patch)
tree3d583b01e5223058bc634c25252d548d653a5fd4 /dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild
parentStable on amd64. Bug #90793. (diff)
downloadgentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.tar.gz
gentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.tar.bz2
gentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1_pre5)
Diffstat (limited to 'dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild')
-rw-r--r--dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild b/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild
new file mode 100644
index 000000000000..639d00c61e5a
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild,v 1.1 2006/02/26 20:23:32 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="TrueType font file access library for Common Lisp"
+HOMEPAGE="http://www.xach.com/lisp/zpb-ttf/"
+SRC_URI="mirror://gentoo/zpb-ttf-${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S=${WORKDIR}/zpb-ttf-${PV}
+
+CLPACKAGE=zpb-ttf
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dohtml *.{html,png}
+ dodoc LICENSE
+}