summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-12-17 12:04:22 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-12-17 12:04:22 +0000
commit75a733a2f02e16d84e0369e3c636da586f400179 (patch)
treec6c20720a7217e5eeaab2e6a02dcecf8337bff84 /dev-lisp/ecls
parentstable x86, bug 291947 (diff)
downloadgentoo-2-75a733a2f02e16d84e0369e3c636da586f400179.tar.gz
gentoo-2-75a733a2f02e16d84e0369e3c636da586f400179.tar.bz2
gentoo-2-75a733a2f02e16d84e0369e3c636da586f400179.zip
Version bump (to improve maxima support), ebuild from the lisp overlay
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'dev-lisp/ecls')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-9.12.3.ebuild63
-rw-r--r--dev-lisp/ecls/files/9.12.3-headers-gentoo.patch17
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 82418576b5ff..42ed04fff0a7 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.29 2009/08/22 06:58:08 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.30 2009/12/17 12:04:22 grozin Exp $
+
+*ecls-9.12.3 (17 Dec 2009)
+
+ 17 Dec 2009; Andrey Grozin <grozin@gentoo.org>
+ +files/9.12.3-headers-gentoo.patch, +ecls-9.12.3.ebuild:
+ Version bump (to improve maxima support), ebuild from the lisp overlay
*ecls-9.8.4 (22 Aug 2009)
diff --git a/dev-lisp/ecls/ecls-9.12.3.ebuild b/dev-lisp/ecls/ecls-9.12.3.ebuild
new file mode 100644
index 000000000000..7cfbfd5c7b6b
--- /dev/null
+++ b/dev-lisp/ecls/ecls-9.12.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-9.12.3.ebuild,v 1.1 2009/12/17 12:04:22 grozin Exp $
+
+EAPI=2
+inherit eutils multilib
+
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+HOMEPAGE="http://common-lisp.net/project/ecl/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+RESTRICT="mirror"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X debug +threads +unicode"
+
+RDEPEND="dev-libs/gmp
+ dev-libs/libffi
+ >=dev-libs/boehm-gc-7.1[threads?]"
+ # cxx? ( dev-libs/boehm-gc[-nocxx] )"
+DEPEND="${RDEPEND}
+ app-text/texi2html"
+PDEPEND="dev-lisp/gentoo-init"
+
+PROVIDE="virtual/commonlisp"
+
+S="${WORKDIR}"/ecl-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+}
+
+src_configure() {
+ # $(use_with cxx)
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-gengc \
+ --enable-longdouble \
+ $(use_enable debug) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with X x) \
+ $(use_with X clx) \
+ || die "econf failed"
+}
+
+src_compile() {
+ #parallel fails
+ emake -j1 || die "make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Could not build ECL"
+
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+}
diff --git a/dev-lisp/ecls/files/9.12.3-headers-gentoo.patch b/dev-lisp/ecls/files/9.12.3-headers-gentoo.patch
new file mode 100644
index 000000000000..635fc5d4afde
--- /dev/null
+++ b/dev-lisp/ecls/files/9.12.3-headers-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Naur ecl-8.12.0.orig/src/h/object.h ecl-8.12.0/src/h/object.h
+--- ecl.orig/src/h/object.h 2008-12-17 16:41:53.000000000 +0100
++++ ecl/src/h/object.h 2008-12-17 19:35:05.000000000 +0100
+@@ -23,8 +23,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
+ typedef int bool;