summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-27 06:22:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-27 06:22:02 +0000
commit131584074cac7cd447c0efbd5b4263c81b92574d (patch)
tree07688ac6694e460900ba13d5d61d5fd9af15aee9 /dev-lisp
parentclean out older, non-modX ebuild (diff)
downloadgentoo-2-131584074cac7cd447c0efbd5b4263c81b92574d.tar.gz
gentoo-2-131584074cac7cd447c0efbd5b4263c81b92574d.tar.bz2
gentoo-2-131584074cac7cd447c0efbd5b4263c81b92574d.zip
New upstream version; Change nosource USE flag to source (no need to define nosource if source already is used globally.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog15
-rw-r--r--dev-lisp/sbcl/files/0.9.16/README.Gentoo30
-rw-r--r--dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-prefix5
-rw-r--r--dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-suffix2
-rw-r--r--dev-lisp/sbcl/files/0.9.16/disable-tests-gentoo.patch54
-rw-r--r--dev-lisp/sbcl/files/0.9.16/install-clc.lisp37
-rw-r--r--dev-lisp/sbcl/files/0.9.16/sbcl.sh65
-rw-r--r--dev-lisp/sbcl/files/0.9.16/sbclrc16
-rw-r--r--dev-lisp/sbcl/files/0.9.16/vanilla-module-install-source-gentoo.patch10
-rw-r--r--dev-lisp/sbcl/files/digest-sbcl-0.9.1621
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.16.ebuild195
11 files changed, 449 insertions, 1 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index d9727226c164..87851db39217 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.92 2006/07/29 06:23:47 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.93 2006/08/27 06:22:02 mkennedy Exp $
+
+*sbcl-0.9.16 (27 Aug 2006)
+
+ 27 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.9.16/README.Gentoo,
+ +files/0.9.16/customize-target-features.lisp-prefix,
+ +files/0.9.16/customize-target-features.lisp-suffix,
+ +files/0.9.16/disable-tests-gentoo.patch, +files/0.9.16/install-clc.lisp,
+ +files/0.9.16/sbcl.sh, +files/0.9.16/sbclrc,
+ +files/0.9.16/vanilla-module-install-source-gentoo.patch,
+ +sbcl-0.9.16.ebuild:
+ New upstream version; Change nosource USE flag to source (no need to define
+ nosource if source already is used globally.
*sbcl-0.9.15 (30 Jul 2006)
diff --git a/dev-lisp/sbcl/files/0.9.16/README.Gentoo b/dev-lisp/sbcl/files/0.9.16/README.Gentoo
new file mode 100644
index 000000000000..f58c4fd7d403
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/README.Gentoo
@@ -0,0 +1,30 @@
+$Id: README.Gentoo,v 1.1 2006/08/27 06:22:02 mkennedy Exp $
+
+Gentoo GNU/Linux specific notes for SBCL
+----------------------------------------
+
+This is the README.Gentoo file from /usr/share/doc/@PF@/ directory.
+
+ * The Gentoo port uses patches from the Debian project's SBCL port.
+
+ * An SBCL with support for multi-threading on GNU/Linux for the x86 and amd64
+ platforms is available with 'USE="threads" emerge dev-lisp/sbcl'. Note, an
+ NPTL-enabled GLIBC is a requirement beginning with SBCL 0.9.5.
+
+ * asdf-install is installed as sbcl-asdf-install (the man-page is similarly
+ named).
+
+ * Support for the Common Lisp Controller is available.
+
+ * If "nosource" is in your USE flags, then SBCL's source will not be installed
+ (in /usr/lib/sbcl/src).
+
+ * If "unicode" is in your USE flags, then support for SBCL
+ Unicode will be included.
+
+ * If "ldb" is in your USE flags, then support for the SBCL low-level debugger
+ will be included.
+
+If you encounter any problems or have suggestions, use http://bugs.gentoo.org.
+Please don't bother the upstream authors unless you are absolutely certain it is
+not Gentoo-related.
diff --git a/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-prefix b/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-prefix
new file mode 100644
index 000000000000..40f9a4fc85fa
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-prefix
@@ -0,0 +1,5 @@
+(lambda (list)
+(flet ((enable (x)
+(pushnew x list))
+(disable (x)
+(setf list (remove x list))))
diff --git a/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-suffix b/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-suffix
new file mode 100644
index 000000000000..dbbde7adc44e
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/customize-target-features.lisp-suffix
@@ -0,0 +1,2 @@
+)
+list)
diff --git a/dev-lisp/sbcl/files/0.9.16/disable-tests-gentoo.patch b/dev-lisp/sbcl/files/0.9.16/disable-tests-gentoo.patch
new file mode 100644
index 000000000000..32ace9fbe0ab
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/disable-tests-gentoo.patch
@@ -0,0 +1,54 @@
+diff -ur sbcl-0.9.14.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd sbcl-0.9.16/contrib/sb-bsd-sockets/sb-bsd-sockets.asd
+--- sbcl-0.9.16.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-06-09 09:11:29.000000000 -0500
++++ sbcl-0.9.16/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-07-09 11:42:19.000000000 -0500
+@@ -42,19 +42,3 @@
+
+ (defmethod perform :after ((o load-op) (c (eql (find-system :sb-bsd-sockets))))
+ (provide 'sb-bsd-sockets))
+-
+-#-win32
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets))))
+- (operate 'load-op 'sb-bsd-sockets-tests)
+- (operate 'test-op 'sb-bsd-sockets-tests))
+-
+-#-win32
+-(defsystem sb-bsd-sockets-tests
+- :depends-on (sb-rt sb-bsd-sockets #-win32 sb-posix)
+- :components ((:file "tests")))
+-
+-#-win32
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets-tests))))
+- (or (funcall (intern "DO-TESTS" (find-package "SB-RT")))
+- (error "test-op failed")))
+-
+diff -ur sbcl-0.9.16.orig/contrib/sb-posix/sb-posix.asd sbcl-0.9.16/contrib/sb-posix/sb-posix.asd
+--- sbcl-0.9.16.orig/contrib/sb-posix/sb-posix.asd 2006-03-07 06:04:27.000000000 -0600
++++ sbcl-0.9.16/contrib/sb-posix/sb-posix.asd 2006-07-09 11:43:16.000000000 -0500
+@@ -22,27 +22,3 @@
+
+ (defmethod perform :after ((o load-op) (c (eql (find-system :sb-posix))))
+ (provide 'sb-posix))
+-
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-posix))))
+- (operate 'load-op 'sb-posix-tests)
+- (operate 'test-op 'sb-posix-tests))
+-
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-posix-tests))))
+- (funcall (intern "DO-TESTS" (find-package "SB-RT")))
+- (let ((failures (funcall (intern "PENDING-TESTS" "SB-RT")))
+- (ignored-failures (loop for sym being the symbols of :sb-posix-tests
+- if (search ".ERROR" (symbol-name sym))
+- collect sym)))
+- (cond
+- ((null failures)
+- t)
+- ((null (set-difference failures ignored-failures))
+- (warn "~@<some POSIX implementations return incorrect error values for ~
+- failing calls, but there is legitimate variation between ~
+- implementations too. If you think the errno ~
+- from your platform is valid, please contact the sbcl ~
+- developers; otherwise, please submit a bug report to your ~
+- kernel distributor~@:>")
+- t)
+- (t
+- (error "non-errno tests failed!")))))
diff --git a/dev-lisp/sbcl/files/0.9.16/install-clc.lisp b/dev-lisp/sbcl/files/0.9.16/install-clc.lisp
new file mode 100644
index 000000000000..8ae9a3828dff
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/install-clc.lisp
@@ -0,0 +1,37 @@
+;;; -*- Mode: LISP; Package: CL-USER -*-
+;;;
+;;; Copyright (C) Peter Van Eynde 2001 and Kevin Rosenberg 2002-2003
+;;;
+;;; License: LGPL v2
+;;;
+
+;; This file is originally from the Debian project patch to SBCL
+;; upstream.
+
+(in-package "COMMON-LISP-USER")
+
+(handler-case
+ (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
+ (error (e)
+ (format t "~%Error during load of common-lisp-controller.lisp: ~A~%" e)
+ (sb-unix:unix-exit 1)))
+
+(handler-case
+ (common-lisp-controller:init-common-lisp-controller-v4 "sbcl")
+ (error (e)
+ (format t "~%Error running init-common-lisp-controller-v4: ~A~%" e)
+ (sb-unix:unix-exit 1)))
+
+(when (probe-file #p"/etc/lisp.config")
+ (load #p"/etc/lisp.config"))
+
+(setf (logical-pathname-translations "SYS")
+ '(("SYS:SRC;**;*.*.*"
+ #P"/usr/share/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*"
+ #P"/usr/share/sbcl/**/*.*")))
+
+(ignore-errors
+ (format t "~%Saving to sbcl-new.core...")
+ (sb-ext:gc :full t)
+ (sb-ext:save-lisp-and-die "sbcl-new.core"))
diff --git a/dev-lisp/sbcl/files/0.9.16/sbcl.sh b/dev-lisp/sbcl/files/0.9.16/sbcl.sh
new file mode 100644
index 000000000000..6693bd9b4e8b
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/sbcl.sh
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+# This file is originally from the Debian project patch to SBCL
+# upstream. It has been modified by the Gentoo project to NOT use
+# /etc/sbcl.rc which has been confusing because SBCL docs refer
+# /etc/sbclrc.
+
+if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
+ cat <<EOF
+$0: cannot find the common-lisp-controller source.
+EOF
+ exit 0
+fi
+
+build_error()
+{
+ echo "Build failure $1"
+ exit 1
+}
+
+case $1 in
+ install-clc)
+ echo $0 loading and dumping clc.
+ ( cd /usr/lib/sbcl
+ /usr/bin/sbcl --core /usr/lib/sbcl/sbcl-dist.core \
+ --noinform --sysinit /etc/sbclrc --userinit /dev/null \
+ --load "/usr/lib/sbcl/install-clc.lisp" # 2> /dev/null
+ mv sbcl-new.core sbcl.core || (echo FAILED ; cp sbcl-dist.core sbcl.core ) )
+ ;;
+ remove-clc)
+ echo $0 removing clc-enabled image
+ cp /usr/lib/sbcl/sbcl-dist.core /usr/lib/sbcl/sbcl.core
+ ;;
+ rebuild)
+ echo $0 rebuilding...
+ shift
+ echo rebuilding $1
+ /usr/bin/sbcl --noinform --sysinit /etc/sbclrc --userinit /dev/null \
+ --disable-debugger \
+ --eval \
+"(handler-case
+ (progn
+ (asdf:operate 'asdf:compile-op (quote $1))
+ (sb-unix:unix-exit 0))
+ (error (e)
+ (ignore-errors (format t \"~&Build error: ~A~%\" e))
+ (finish-output)
+ (sb-unix:unix-exit 1)))" || build_error
+ ;;
+ remove)
+ echo $0 removing packages...
+ shift
+ while [ ! -z "$1" ] ; do
+ rm -rf "/var/cache/common-lisp-controller/*/sbcl/${1}"
+ shift
+ done
+ ;;
+ *)
+ echo $0 unkown command $1
+ echo known commands: rebuild, remove, install-clc, and remove-clc
+ exit 1
+ ;;
+esac
+
+exit 0 \ No newline at end of file
diff --git a/dev-lisp/sbcl/files/0.9.16/sbclrc b/dev-lisp/sbcl/files/0.9.16/sbclrc
new file mode 100644
index 000000000000..bd0ab76b6adf
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/sbclrc
@@ -0,0 +1,16 @@
+;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Package: CL-USER -*-
+
+;;; This file is installed as /etc/sbclrc and run on every invocation
+;;; of SBCL
+
+(if (probe-file "/etc/lisp-config.lisp")
+ (load "/etc/lisp-config.lisp")
+ (format t "~%;;; Warning: there is no /etc/lisp-config.lisp file"))
+
+;;; The following is required if you want source location functions to
+;;; work (such as those called when you use M-. (edit definition) in
+;;; ILISP or SLIME)
+
+(setf (logical-pathname-translations "SYS")
+ '(("SYS:SRC;**;*.*.*" #p"/usr/lib/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*" #p"/usr/lib/sbcl/**/*.*")))
diff --git a/dev-lisp/sbcl/files/0.9.16/vanilla-module-install-source-gentoo.patch b/dev-lisp/sbcl/files/0.9.16/vanilla-module-install-source-gentoo.patch
new file mode 100644
index 000000000000..e66894607647
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.16/vanilla-module-install-source-gentoo.patch
@@ -0,0 +1,10 @@
+diff -ur sbcl-0.9.16.orig/contrib/vanilla-module.mk sbcl-0.9.16/contrib/vanilla-module.mk
+--- sbcl-0.9.16.orig/contrib/vanilla-module.mk 2003-11-08 09:04:47.000000000 -0600
++++ sbcl-0.9.16/contrib/vanilla-module.mk 2006-05-29 22:49:12.000000000 -0500
+@@ -5,4 +5,4 @@
+ test:: $(MODULE).fasl
+
+ install:
+- cp $(MODULE).fasl $(BUILD_ROOT)$(INSTALL_DIR)
++ cp $(MODULE).fasl $(MODULE).lisp $(BUILD_ROOT)$(INSTALL_DIR)
+
diff --git a/dev-lisp/sbcl/files/digest-sbcl-0.9.16 b/dev-lisp/sbcl/files/digest-sbcl-0.9.16
new file mode 100644
index 000000000000..584ca23c990e
--- /dev/null
+++ b/dev-lisp/sbcl/files/digest-sbcl-0.9.16
@@ -0,0 +1,21 @@
+MD5 29ad145f1fc45c65b8d65b39013bc43f sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+RMD160 d9c34e109dd307bfe652ef57d5837c83cbc60055 sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+SHA256 90bff80973c3e295b5ecdd0b59525583ae04cb2d5967378af65e04ac77fad660 sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+MD5 3a72d0785ce0a8e02f9af632c2a4f217 sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+RMD160 0e73b6e96f0170d44be60dfde8bf580596d3a6ee sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+SHA256 fef30a771530096c4f190c60d9d7c396844fc67a3ec2bbaae9b0ff497f925129 sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+MD5 029b85186984d0bfc8b49c4de1e8e45e sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+RMD160 41015dcfb41caf93b54a02a0f55eec994309accf sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+SHA256 f0bc5fc11e9c0f1651ebe773b5c7e972da589cc4af2811d25438a099f490cc7d sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+MD5 46d67859cac0d3b748310a93311b308a sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+RMD160 c60dba2a0278acf787d53a93ebac4de03c1d5ed8 sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+SHA256 5cb563b19d1dd828e55bde9763404f5b908c9f5a043ba8c443415291b969b3d9 sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+MD5 033b04259a929e71393281981fdf1f7a sbcl-0.9.14-x86-64-linux-binary.tar.bz2 7225013
+RMD160 7a544bedebd4389eb75fe67bb48c0d25f677bc0d sbcl-0.9.14-x86-64-linux-binary.tar.bz2 7225013
+SHA256 3db39ce36b1efc42cf99fc1be355aa8c0107e60ffb56f50bb001cc9b5cab70eb sbcl-0.9.14-x86-64-linux-binary.tar.bz2 7225013
+MD5 5a703f5dd196ed246fd84f4f58314995 sbcl-0.9.14-x86-linux-binary.tar.bz2 7517927
+RMD160 039968db40389a481da29dcc310aa05a50ee6ac6 sbcl-0.9.14-x86-linux-binary.tar.bz2 7517927
+SHA256 f1add7f9c76e1ea45f17b752a62f5ad5d1fb4d27d06ae5ebfed05629bba9fafa sbcl-0.9.14-x86-linux-binary.tar.bz2 7517927
+MD5 0117cc7af9ff701c8bf10c4ea048fdac sbcl-0.9.16-source.tar.bz2 2766768
+RMD160 354137ab9c602dd008f9937f634d563511f7b753 sbcl-0.9.16-source.tar.bz2 2766768
+SHA256 33baf9044638a5d36910212c3e6be1abb233a0404d3c3e1788cfee01742609a9 sbcl-0.9.16-source.tar.bz2 2766768
diff --git a/dev-lisp/sbcl/sbcl-0.9.16.ebuild b/dev-lisp/sbcl/sbcl-0.9.16.ebuild
new file mode 100644
index 000000000000..de95c18b7b3f
--- /dev/null
+++ b/dev-lisp/sbcl/sbcl-0.9.16.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.16.ebuild,v 1.1 2006/08/27 06:22:02 mkennedy Exp $
+
+inherit common-lisp-common-2 eutils flag-o-matic
+
+BV_X86=0.9.14
+BV_PPC=0.8.15
+BV_SPARC=0.8.15
+BV_MIPS=0.7.10
+BV_AMD64=0.9.14
+BV_PPC_MACOS=0.9.11a
+
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
+ x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
+ ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-powerpc-linux-binary.tar.bz2 )
+ sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
+ mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )
+ amd64? ( mirror://sourceforge/sbcl/${PN}-${BV_AMD64}-x86-64-linux-binary.tar.bz2 )
+ ppc-macos? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC_MACOS}-powerpc-darwin-binary.tar.bz2 )"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+
+IUSE="ldb source threads unicode doc"
+
+DEPEND=">=dev-lisp/common-lisp-controller-5.13
+ >=dev-lisp/cl-asdf-1.84
+ doc? ( sys-apps/texinfo )"
+
+PROVIDE="virtual/commonlisp"
+
+MY_WORK=${WORKDIR}/files
+
+sbcl_einfo() {
+ local method
+ case $# in
+ 0) method=einfo;;
+ 1) method=$1;;
+ *) die "Invalid number of arguments to scbl_einfo"
+ esac
+ $method ""; while read line; do $method "${line}"; done; $method ""
+}
+
+pkg_setup() {
+ if built_with_use sys-devel/gcc hardened && gcc-config -c |grep -qv vanilla; then
+ sbcl_einfo eerror <<'EOF'
+So-called "hardened" compiler features are incompatible with SBCL. You
+must use gcc-config to select a profile with non-hardened features
+(the "vanilla" profile) and "source /etc/profile" before continuing.
+EOF
+ die
+ fi
+ if ! built_with_use sys-libs/glibc nptl && (use x86 || use amd64); then
+ sbcl_einfo eerror <<'EOF'
+Building SBCL without NPTL support on at least x86 and amd64
+architectures is not a supported configuration in Gentoo. Please
+refer to Bug #119016 for more information.
+EOF
+ die
+ fi
+ if (use ppc-macos || use ppc) && use ldb; then
+ sbcl_einfo ewarn <<'EOF'
+Building SBCL on PPC with LDB support is not a supported configuration
+in Gentoo. Please refer to Bug #121830 for more information.
+Continuing with LDB support disabled.
+EOF
+ fi
+}
+
+src_unpack() {
+ local a
+
+ mkdir -p ${MY_WORK}
+ cp ${FILESDIR}/${PV}/* ${MY_WORK}
+ sed -i "s,/usr/lib,/usr/$(get_libdir),g" ${MY_WORK}/*
+
+ # `use ppc` returns true for both ppc linux and ppc-macos systems
+ # specify
+ if use ppc-macos ; then
+ a="${PN}-${BV_PPC_MACOS}-powerpc-darwin-binary.tar.bz2"
+ elif use ppc; then
+ a="${PN}-${BV_PPC}-powerpc-linux-binary.tar.bz2"
+ else
+ for a in ${A}; do [[ $a == *binary* ]] && break; done
+ fi
+
+ unpack $a
+ mv ${PN}* sbcl-binary || die
+
+ unpack ${P}-source.tar.bz2
+ epatch ${MY_WORK}/disable-tests-gentoo.patch || die
+ epatch ${MY_WORK}/vanilla-module-install-source-gentoo.patch || die
+ sed -i "s,/lib,/$(get_libdir),g" ${S}/install.sh
+ sed -i "s,/usr/local/lib,/usr/$(get_libdir),g" \
+ ${S}/src/runtime/runtime.c # #define SBCL_HOME ...
+
+ cp ${MY_WORK}/customize-target-features.lisp-prefix \
+ ${S}/customize-target-features.lisp
+ if use x86 || use amd64; then
+ use threads && echo '(enable :sb-thread)' \
+ >>${S}/customize-target-features.lisp
+ fi
+ if (use ppc-macos || use ppc) && use ldb; then
+ sbcl_einfo ewarn <<'EOF'
+Excluding LDB support for ppc-macos or ppc.
+EOF
+ else
+ use ldb \
+ && echo '(enable :sb-ldb)' \
+ >>${S}/customize-target-features.lisp
+ fi
+ echo '(disable :sb-test)' >>${S}/customize-target-features.lisp
+ ! use unicode \
+ && echo '(disable :sb-unicode)' \
+ >>${S}/customize-target-features.lisp
+ cat ${MY_WORK}/customize-target-features.lisp-suffix \
+ >>${S}/customize-target-features.lisp
+
+ find ${S} -type f -name .cvsignore -print0 | xargs -0 rm -f
+ find ${S} -depth -type d -name CVS -print0 | xargs -0 rm -rf
+ find ${S} -type f -name \*.c -print0 | xargs -0 chmod 644
+}
+
+src_compile() {
+ local bindir="${WORKDIR}/sbcl-binary"
+
+ filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+
+ LANG=C PATH=${bindir}/src/runtime:${PATH} SBCL_HOME=${bindir}/output GNUMAKE=make \
+ ./make.sh 'sbcl
+ --sysinit /dev/null
+ --userinit /dev/null
+ --disable-debugger
+ --core ${bindir}/output/sbcl.core' \
+ || die
+ if use doc; then
+ cd ${S}/doc/manual
+ LANG=C make info html || die
+ fi
+}
+
+src_install() {
+ unset SBCL_HOME
+
+ insinto /etc/
+ doins ${MY_WORK}/sbclrc || die # Gentoo specific (from Debian)
+ dosed "s,/usr/lib/,/usr/$(get_libdir)/,g" /etc/sbclrc
+
+ exeinto /usr/$(get_libdir)/common-lisp/bin
+ doexe ${MY_WORK}/sbcl.sh || die # Gentoo specific (from Debian)
+
+ dodir /usr/share/man
+ dodir /usr/share/doc/${PF}
+ INSTALL_ROOT=${D}/usr DOC_DIR=${D}/usr/share/doc/${PF} sh install.sh || die
+ mv ${D}/usr/$(get_libdir)/sbcl/sbcl.core ${D}/usr/$(get_libdir)/sbcl/sbcl-dist.core || die
+
+ insinto /usr/$(get_libdir)/sbcl
+ doins ${MY_WORK}/install-clc.lisp # Gentoo specific (from Debian)
+
+ doman doc/sbcl-asdf-install.1
+
+ dodoc BUGS COPYING CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES README STYLE SUPPORT TLA TODO
+ dodoc ${MY_WORK}/README.Gentoo
+
+ if use doc; then
+ dohtml doc/html/*
+ doinfo ${S}/doc/manual/*.info*
+ fi
+
+ keepdir /usr/$(get_libdir)/common-lisp/sbcl
+
+ if ! use nosource; then
+ # install the SBCL source
+ cp -pPR ${S}/src ${D}/usr/$(get_libdir)/sbcl
+ find ${D}/usr/$(get_libdir)/sbcl/src -type f -name \*.fasl -print0 | xargs -0 rm -f
+ fi
+
+ impl-save-timestamp-hack sbcl || die
+}
+
+pkg_postinst() {
+ LANG=C standard-impl-postinst sbcl
+}
+
+pkg_postrm() {
+ LANG=C standard-impl-postrm sbcl /usr/bin/sbcl
+ if [ ! -x /usr/bin/sbcl ]; then
+ rm -rf /usr/$(get_libdir)/sbcl/ || die
+ fi
+}