summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-06 22:51:55 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-06-06 22:51:55 +0000
commit35fe513c4530266015b02b06dc2f0be8224b2bf2 (patch)
tree790f584aa24db12a1b10c7e1dfaba1595e8f7186 /dev-lisp
parentstable release (diff)
downloadgentoo-2-35fe513c4530266015b02b06dc2f0be8224b2bf2.tar.gz
gentoo-2-35fe513c4530266015b02b06dc2f0be8224b2bf2.tar.bz2
gentoo-2-35fe513c4530266015b02b06dc2f0be8224b2bf2.zip
Fixes #3401.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cmucl-bin/ChangeLog37
-rw-r--r--dev-lisp/cmucl-bin/cmucl-bin-18d.ebuild26
-rw-r--r--dev-lisp/cmucl-bin/files/digest-cmucl-bin-18d2
-rw-r--r--dev-lisp/cmucl-bin/files/wrapper.patch19
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-lisp/cmucl-bin/ChangeLog b/dev-lisp/cmucl-bin/ChangeLog
new file mode 100644
index 000000000000..47c5265b424b
--- /dev/null
+++ b/dev-lisp/cmucl-bin/ChangeLog
@@ -0,0 +1,37 @@
+# ChangeLog for dev-lisp/cmucl-bin
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl-bin/ChangeLog,v 1.1 2002/06/06 22:51:55 karltk Exp $
+
+*cmucl-bin-18d (07 Jun 2002)
+
+ 07 Jun 2002; Karl Trygve Kalleberg <karltk@gentoo.org> cmucl-bin-18d.ebuild files/digest-cmucl-bin-18d :
+
+ From the web page:
+
+ CMUCL is a free implementation of the Common Lisp programming language
+ which runs on most major Unix platforms. It mainly conforms to the ANSI
+ Common Lisp standard. Here is a summary of its main features:
+
+ * a sophisticated native-code compiler which is capable of powerful
+ type inferences, and generates code competitive in speed with C
+ compilers.
+ * generational garbage collection and multiprocessing capability on
+ the x86 ports.
+ * a foreign function interface which allows interfacing with C code
+ and system libraries, including shared libraries on most
+ platforms, and direct access to Unix system calls.
+ * support for interprocess communication and remote procedure calls.
+ * an implementation of CLOS, the Common Lisp Object System, which
+ includes multimethods and a metaobject protocol.
+ * a graphical source-level debugger using a Motif interface, and a
+ code profiler.
+ * an interface to the X11 Window System (CLX), and a sophisticated
+ graphical widget library (Garnet).
+ * programmer-extensible input and output streams.
+ * an Emacs-like editor implemented in Common Lisp.
+ * public domain: free, with full source code and no strings attached
+ (and no warranty). Like the GNU/Linux and *BSD operating systems,
+ CMUCL is maintained and improved by a team of volunteers
+ collaborating over the Internet.
+
+ Ebuild contributed by Thomas L. Bevan <tom@regex.com.au>.
diff --git a/dev-lisp/cmucl-bin/cmucl-bin-18d.ebuild b/dev-lisp/cmucl-bin/cmucl-bin-18d.ebuild
new file mode 100644
index 000000000000..875d7cd9433f
--- /dev/null
+++ b/dev-lisp/cmucl-bin/cmucl-bin-18d.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl-bin/cmucl-bin-18d.ebuild,v 1.1 2002/06/06 22:51:55 karltk Exp $
+
+DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
+HOMEPAGE="http://www.cons.org/cmucl/index.html"
+LICENSE="PD"
+DEPEND=""
+RDEPEND="$DEPEND"
+SLOT="0"
+SRC_ROOT="ftp://ftp.cn.freebsd.org/pub/cmucl/release/18d/"
+SRC_URI="$SRC_ROOT/cmucl-18d-x86-linux.tar.bz2
+ $SRC_ROOT/cmucl-18d-x86-linux.extra.tar.bz2"
+S=${WORKDIR}
+
+src_install () {
+ patch -p1 < ${FILESDIR}/wrapper.patch || die "Failed to apply patch"
+ into /opt/cmucl || die
+ dobin bin/* || die
+ dodoc doc/cmucl/* || die
+ find lib -type f | xargs dolib || die
+ mv lib/cmucl/sample-wrapper cmucl || die "Failed to copy wrapper script"
+ exeinto /usr/bin
+ doexe cmucl || die "Failed to insert executable"
+}
+
diff --git a/dev-lisp/cmucl-bin/files/digest-cmucl-bin-18d b/dev-lisp/cmucl-bin/files/digest-cmucl-bin-18d
new file mode 100644
index 000000000000..cd71ad8a1ece
--- /dev/null
+++ b/dev-lisp/cmucl-bin/files/digest-cmucl-bin-18d
@@ -0,0 +1,2 @@
+MD5 1b997e621e639f75b0a4c31417168421 cmucl-18d-x86-linux.tar.bz2 6150729
+MD5 7621965556cab0498d9bb84803e70cd8 cmucl-18d-x86-linux.extra.tar.bz2 3627147
diff --git a/dev-lisp/cmucl-bin/files/wrapper.patch b/dev-lisp/cmucl-bin/files/wrapper.patch
new file mode 100644
index 000000000000..94f7279431cc
--- /dev/null
+++ b/dev-lisp/cmucl-bin/files/wrapper.patch
@@ -0,0 +1,19 @@
+diff -ru lisp/lib/cmucl/sample-wrapper lisp2/lib/cmucl/sample-wrapper
+--- lisp/lib/cmucl/sample-wrapper Thu Apr 11 06:31:24 2002
++++ lisp2/lib/cmucl/sample-wrapper Wed Jun 5 14:59:18 2002
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+ #
+ # Set up CMUCLLIB environment variable to point to run-time files.
+-CMUCLLIB=/<<your-cmucl-path>>/lib/cmucl/lib
++CMUCLLIB=/opt/cmucl/lib
+ export CMUCLLIB
+
+ #
+@@ -13,4 +13,4 @@
+
+ #
+ # Run Lisp with these environment variables set.
+-exec /<<your-cmucl-path>>/bin/lisp "$@"
++exec /opt/cmucl/bin/lisp "$@"
+