summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-12-16 19:59:34 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-12-16 19:59:34 +0000
commit5ab4f400c24bc4914dcd55aa0a9ae262b4f7949b (patch)
tree106d4bcdb698d14cd8f76abed84baeed7a1db0a0 /dev-lisp
parentarm/hppa/ia64/s390 stable for #74656 (Manifest recommit) (diff)
downloadgentoo-2-5ab4f400c24bc4914dcd55aa0a9ae262b4f7949b.tar.gz
gentoo-2-5ab4f400c24bc4914dcd55aa0a9ae262b4f7949b.tar.bz2
gentoo-2-5ab4f400c24bc4914dcd55aa0a9ae262b4f7949b.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-aim/Manifest3
-rw-r--r--dev-lisp/cl-aim/cl-aim-1.1.ebuild34
-rw-r--r--dev-lisp/cl-aim/files/1.1-trivial-sockets-gentoo.patch76
-rw-r--r--dev-lisp/cl-aim/files/digest-cl-aim-1.11
-rw-r--r--dev-lisp/cl-aim/metadata.xml10
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-lisp/cl-aim/Manifest b/dev-lisp/cl-aim/Manifest
new file mode 100644
index 000000000000..b9474c027b43
--- /dev/null
+++ b/dev-lisp/cl-aim/Manifest
@@ -0,0 +1,3 @@
+MD5 e3d427b0ff7291b1a847a50199c0d750 cl-aim-1.1.ebuild 822
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 b3c73da3b07ef5e1e1101296e31f9005 files/digest-cl-aim-1.1 60
diff --git a/dev-lisp/cl-aim/cl-aim-1.1.ebuild b/dev-lisp/cl-aim/cl-aim-1.1.ebuild
new file mode 100644
index 000000000000..cf9d2f27128e
--- /dev/null
+++ b/dev-lisp/cl-aim/cl-aim-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aim/cl-aim-1.1.ebuild,v 1.1 2004/12/16 19:59:34 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp interface to AOL's TOC instant messaging protocol"
+HOMEPAGE="http://claim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/claim/claim_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-trivial-sockets"
+
+S=${WORKDIR}/claim_${PV}
+
+CLPACKAGE=claim
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-trivial-sockets-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.lisp claim.asd
+ common-lisp-system-symlink
+ dodoc LICENSE.txt PROTOCOL.txt README
+ docinto examples
+ dodoc examples/gossip-bot.lisp
+}
diff --git a/dev-lisp/cl-aim/files/1.1-trivial-sockets-gentoo.patch b/dev-lisp/cl-aim/files/1.1-trivial-sockets-gentoo.patch
new file mode 100644
index 000000000000..4707cbec2b98
--- /dev/null
+++ b/dev-lisp/cl-aim/files/1.1-trivial-sockets-gentoo.patch
@@ -0,0 +1,76 @@
+diff -urN claim_1.1.orig/claim.asd claim_1.1/claim.asd
+--- claim_1.1.orig/claim.asd 2004-10-30 02:59:54.000000000 -0500
++++ claim_1.1/claim.asd 2004-12-15 23:17:24.000000000 -0600
+@@ -19,9 +19,8 @@
+ :maintainer "John Wiseman <jjwiseman@yahoo.com>"
+ :licence "MIT"
+ :description "Common Lisp AOL Instant Messenger (AIM) client interface, or CLAIM"
+- :long-description "CLAIM provides a client interface to AOL's Instant Messaging network using the TOC protocol. CLAIM supports ACL, LispWorks, OpenMCL and SBCL."
+-
++ :long-description "CLAIM provides a client interface to AOL's Instant Messaging network using the TOC protocol. CLAIM supports Lisp implmenetations supported by the TRIVIAL-SOCKETS package."
+ :components ((:file "package")
+- (:file "sysdeps" :depends-on ("package"))
+- (:file "claim" :depends-on ("package" "sysdeps")))
+- :depends-on (#+sbcl :sb-bsd-sockets))
++ (:file "claim" :depends-on ("package")))
++ :depends-on (:trivial-sockets))
++
+diff -urN claim_1.1.orig/claim.lisp claim_1.1/claim.lisp
+--- claim_1.1.orig/claim.lisp 2004-10-30 14:14:43.000000000 -0500
++++ claim_1.1/claim.lisp 2004-12-15 23:26:27.000000000 -0600
+@@ -90,9 +90,8 @@
+
+ (defmethod open-socket ((self aim-connection))
+ (trace-log self "Opening socket to TOC server.")
+- (or (make-tcp-socket (aim-connection-toc-host self)
+- (aim-connection-toc-port self))
+- (error "Unable to connect.")))
++ (trivial-sockets:open-stream (aim-connection-toc-host self)
++ (aim-connection-toc-port self)))
+
+
+ (defstruct toc-event
+diff -urN claim_1.1.orig/sysdeps.lisp claim_1.1/sysdeps.lisp
+--- claim_1.1.orig/sysdeps.lisp 2004-10-30 14:14:43.000000000 -0500
++++ claim_1.1/sysdeps.lisp 1969-12-31 18:00:00.000000000 -0600
+@@ -1,39 +0,0 @@
+-;;; ------------------------------------------------- -*- Mode: LISP -*-
+-;;; CLAIM -- An implementation of the AIM TOC protocol in Lisp.
+-;;;
+-;;; Copyright 2001, 2002, 2004 I/NET Inc. (http://www.inetmi.com/)
+-;;; John Wiseman (jjwiseman@yahoo.com)
+-;;; 2004-10-29
+-;;;
+-;;; Licensed under the MIT license--see the accompanying LICENSE.txt
+-;;; file.
+-;;;
+-;;; Lisp-specific functions.
+-
+-(in-package :common-lisp)
+-
+-(defun com.lemonodor.claim::make-tcp-socket (host port)
+- #+openmcl
+- (ccl:make-socket :connect :active
+- :remote-host host
+- :remote-port port)
+- #+allegro
+- (socket:make-socket :connect :active
+- :remote-host host
+- :remote-port port)
+- #+lispworks
+- (comm:open-tcp-stream host port)
+- #+sbcl
+- (let ((socket (make-instance 'sb-bsd-sockets:inet-socket
+- :type :stream
+- :protocol :tcp)))
+- (sb-bsd-sockets:socket-connect socket
+- (car (sb-bsd-sockets:host-ent-addresses
+- (sb-bsd-sockets:get-host-by-name host)))
+- port)
+- (sb-bsd-sockets:socket-make-stream socket
+- :element-type 'character
+- :input T
+- :output T
+- :buffering :none))
+- )
+\ No newline at end of file
diff --git a/dev-lisp/cl-aim/files/digest-cl-aim-1.1 b/dev-lisp/cl-aim/files/digest-cl-aim-1.1
new file mode 100644
index 000000000000..cfa38dbd7c98
--- /dev/null
+++ b/dev-lisp/cl-aim/files/digest-cl-aim-1.1
@@ -0,0 +1 @@
+MD5 16e46d01c7c5681f2c4c56969d8686ca claim_1.1.tar.gz 14899
diff --git a/dev-lisp/cl-aim/metadata.xml b/dev-lisp/cl-aim/metadata.xml
new file mode 100644
index 000000000000..31bcd1b74fd9
--- /dev/null
+++ b/dev-lisp/cl-aim/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CLAIM is a Common Lisp interface to AOL's TOC instant messaging protocol. This
+port has been improved by Gentoo to include support the TRIVIAL-SOCKETS package,
+allowing CLAIM to work on a wider range of Lisp implementations.
+</longdescription>
+</pkgmetadata>