summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-11-29 20:41:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-11-29 20:41:37 +0000
commit76586601f2ab845f118c47cfe94472554af0c378 (patch)
treeef380645a4262c1630e297fecc6e56c7c5f4cde8 /dev-lisp
parent*** empty log message *** (diff)
downloadgentoo-2-76586601f2ab845f118c47cfe94472554af0c378.tar.gz
gentoo-2-76586601f2ab845f118c47cfe94472554af0c378.tar.bz2
gentoo-2-76586601f2ab845f118c47cfe94472554af0c378.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-syslog/ChangeLog9
-rw-r--r--dev-lisp/cl-syslog/Manifest6
-rw-r--r--dev-lisp/cl-syslog/cl-syslog-0.9.1.ebuild33
-rw-r--r--dev-lisp/cl-syslog/files/digest-cl-syslog-0.9.11
-rw-r--r--dev-lisp/cl-syslog/metadata.xml12
5 files changed, 58 insertions, 3 deletions
diff --git a/dev-lisp/cl-syslog/ChangeLog b/dev-lisp/cl-syslog/ChangeLog
new file mode 100644
index 000000000000..bf5382bffbc1
--- /dev/null
+++ b/dev-lisp/cl-syslog/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/cl-syslog
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-syslog/ChangeLog,v 1.1 2003/11/29 20:41:34 mkennedy Exp $
+
+*cl-syslog-0.9.1 (29 Nov 2003)
+
+ 29 Nov 2003; <mkennedy@gentoo.org> cl-syslog-0.9.1.ebuild, metadata.xml:
+ initial import. ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-syslog/Manifest b/dev-lisp/cl-syslog/Manifest
index fb0678692d4c..0c038319e077 100644
--- a/dev-lisp/cl-syslog/Manifest
+++ b/dev-lisp/cl-syslog/Manifest
@@ -1,4 +1,4 @@
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 5c020391a8a9e6f0fdb3362834a0df76 cl-syslog-0.9.1.ebuild 872
-MD5 45ee1a6e1cb69b47cae336baf233de8b cl-syslog-0.9.1.ebuild~ 880
+MD5 b379aa8d1fae982a74023c7e8d17827a metadata.xml 479
+MD5 200063b7c11d84f86da87483b813b5da cl-syslog-0.9.1.ebuild 878
+MD5 141d019fd9225bcaea7da1c3ead63ace ChangeLog 407
MD5 018138c1f1cccb965321dd1de1984344 files/digest-cl-syslog-0.9.1 65
diff --git a/dev-lisp/cl-syslog/cl-syslog-0.9.1.ebuild b/dev-lisp/cl-syslog/cl-syslog-0.9.1.ebuild
new file mode 100644
index 000000000000..fcc02a6750d0
--- /dev/null
+++ b/dev-lisp/cl-syslog/cl-syslog-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-syslog/cl-syslog-0.9.1.ebuild,v 1.1 2003/11/29 20:41:34 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="cl-syslog is a Common Lisp library that provides access to the syslog logging facility under Unix."
+HOMEPAGE="http://common-lisp.net/project/cl-syslog/"
+SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-uffi"
+
+CLPACKAGE=cl-syslog
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CREDITS LICENSE README
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-syslog/files/digest-cl-syslog-0.9.1 b/dev-lisp/cl-syslog/files/digest-cl-syslog-0.9.1
new file mode 100644
index 000000000000..e9a0e1b83024
--- /dev/null
+++ b/dev-lisp/cl-syslog/files/digest-cl-syslog-0.9.1
@@ -0,0 +1 @@
+MD5 5e8a018782c0dc2868e227fce30ddbae cl-syslog_0.9.1.tar.gz 3356
diff --git a/dev-lisp/cl-syslog/metadata.xml b/dev-lisp/cl-syslog/metadata.xml
new file mode 100644
index 000000000000..3e9d7a928e27
--- /dev/null
+++ b/dev-lisp/cl-syslog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+cl-syslog is a Common Lisp library that provides access to the syslog
+logging facility under Unix. The code was taken from OnShore's ODCL
+and has been enhanced to include an ASDF system, conditions, options
+to openlog(3) and it now uses UFFI instead of CMUCL-specific FFI
+code.
+</longdescription>
+</pkgmetadata>