summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 19:40:42 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 19:40:42 +0000
commitf34af64bbeaa0c42e3382338703fe692332f98e5 (patch)
treeb0b2ca5872d5704dcacd0a9073dffd98f207eea3 /dev-lisp
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-f34af64bbeaa0c42e3382338703fe692332f98e5.tar.gz
gentoo-2-f34af64bbeaa0c42e3382338703fe692332f98e5.tar.bz2
gentoo-2-f34af64bbeaa0c42e3382338703fe692332f98e5.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-12.12.1-r5.ebuild8
-rw-r--r--dev-lisp/ecls/ecls-13.5.1-r1.ebuild8
-rw-r--r--dev-lisp/ecls/ecls-13.5.1.ebuild8
4 files changed, 18 insertions, 14 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index f634ad587f76..8f76f2fb7cdd 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/ecls
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.50 2014/08/10 20:41:36 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.51 2015/01/28 19:40:42 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> ecls-12.12.1-r5.ebuild,
+ ecls-13.5.1-r1.ebuild, ecls-13.5.1.ebuild:
+ Switch to CPU_FLAGS_X86.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> ecls-10.4.1.ebuild,
ecls-11.1.1-r1.ebuild, ecls-12.12.1-r5.ebuild, ecls-12.12.1.ebuild,
diff --git a/dev-lisp/ecls/ecls-12.12.1-r5.ebuild b/dev-lisp/ecls/ecls-12.12.1-r5.ebuild
index 500a518a9468..ca75d562aeb6 100644
--- a/dev-lisp/ecls/ecls-12.12.1-r5.ebuild
+++ b/dev-lisp/ecls/ecls-12.12.1-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.12.1-r5.ebuild,v 1.2 2014/08/10 20:41:36 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.12.1-r5.ebuild,v 1.3 2015/01/28 19:40:42 mgorny Exp $
EAPI=5
inherit eutils multilib
@@ -15,7 +15,7 @@ RESTRICT="mirror"
LICENSE="BSD LGPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug emacs gengc precisegc sse +threads +unicode X"
+IUSE="debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
CDEPEND="dev-libs/gmp
virtual/libffi
@@ -52,7 +52,7 @@ src_configure() {
$(use_enable gengc) \
$(use_enable precisegc) \
$(use_with debug debug-cflags) \
- $(use_with sse) \
+ $(use_with cpu_flags_x86_sse sse) \
$(use_enable threads) \
$(use_with threads __thread) \
$(use_enable unicode) \
diff --git a/dev-lisp/ecls/ecls-13.5.1-r1.ebuild b/dev-lisp/ecls/ecls-13.5.1-r1.ebuild
index 288bddbf73bf..3d4aadfc3f53 100644
--- a/dev-lisp/ecls/ecls-13.5.1-r1.ebuild
+++ b/dev-lisp/ecls/ecls-13.5.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-13.5.1-r1.ebuild,v 1.3 2014/08/10 20:41:36 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-13.5.1-r1.ebuild,v 1.4 2015/01/28 19:40:42 mgorny Exp $
EAPI=5
inherit eutils multilib
@@ -17,7 +17,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
LICENSE="BSD LGPL-2"
SLOT="0/${PV}"
KEYWORDS="amd64 ~ppc ~sparc ~x86"
-IUSE="debug emacs gengc precisegc sse +threads +unicode X"
+IUSE="debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
CDEPEND="dev-libs/gmp
virtual/libffi
@@ -55,7 +55,7 @@ src_configure() {
$(use_enable gengc) \
$(use_enable precisegc) \
$(use_with debug debug-cflags) \
- $(use_with sse) \
+ $(use_with cpu_flags_x86_sse sse) \
$(use_enable threads) \
$(use_with threads __thread) \
$(use_enable unicode) \
diff --git a/dev-lisp/ecls/ecls-13.5.1.ebuild b/dev-lisp/ecls/ecls-13.5.1.ebuild
index e9b2b3a27492..dc7588ff45ba 100644
--- a/dev-lisp/ecls/ecls-13.5.1.ebuild
+++ b/dev-lisp/ecls/ecls-13.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-13.5.1.ebuild,v 1.3 2014/08/10 20:41:36 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-13.5.1.ebuild,v 1.4 2015/01/28 19:40:42 mgorny Exp $
EAPI=5
inherit eutils multilib
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
LICENSE="BSD LGPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug emacs gengc precisegc sse +threads +unicode X"
+IUSE="debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
CDEPEND="dev-libs/gmp
virtual/libffi
@@ -50,7 +50,7 @@ src_configure() {
$(use_enable gengc) \
$(use_enable precisegc) \
$(use_with debug debug-cflags) \
- $(use_with sse) \
+ $(use_with cpu_flags_x86_sse sse) \
$(use_enable threads) \
$(use_with threads __thread) \
$(use_enable unicode) \