summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-11 01:10:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-11 01:10:11 +0000
commitebf1fad5e39d73c0a84b360677b2b526985bcc5b (patch)
tree74cec7be2426018e52c30bd55af0cda7565132d9 /dev-lua
parentbump ebuild based on ebuild supplied by July Tikhonov in bug #484034 (diff)
downloadgentoo-2-ebf1fad5e39d73c0a84b360677b2b526985bcc5b.tar.gz
gentoo-2-ebf1fad5e39d73c0a84b360677b2b526985bcc5b.tar.bz2
gentoo-2-ebf1fad5e39d73c0a84b360677b2b526985bcc5b.zip
Bump per bug #551710.
(Portage version: 2.2.16/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lgi/ChangeLog8
-rw-r--r--dev-lua/lgi/lgi-0.7.2.ebuild4
-rw-r--r--dev-lua/lgi/lgi-0.9.0.ebuild54
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-lua/lgi/ChangeLog b/dev-lua/lgi/ChangeLog
index 46c7feda84c2..c6ade40a6d5e 100644
--- a/dev-lua/lgi/ChangeLog
+++ b/dev-lua/lgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/lgi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.10 2015/06/06 19:38:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.11 2015/06/11 01:10:11 robbat2 Exp $
+
+*lgi-0.9.0 (11 Jun 2015)
+
+ 11 Jun 2015; Robin H. Johnson <robbat2@gentoo.org> +lgi-0.9.0.ebuild,
+ lgi-0.7.2.ebuild:
+ Bump per bug #551710.
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-lua/lgi/lgi-0.7.2.ebuild b/dev-lua/lgi/lgi-0.7.2.ebuild
index 8f16ff88fd60..5a563142c20e 100644
--- a/dev-lua/lgi/lgi-0.7.2.ebuild
+++ b/dev-lua/lgi/lgi-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/lgi-0.7.2.ebuild,v 1.7 2015/04/02 18:22:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/lgi-0.7.2.ebuild,v 1.8 2015/06/11 01:10:11 robbat2 Exp ${PV}.ebuild,v 1.7 2015/04/02 18:22:41 mr_bones_ Exp $
EAPI=4
@@ -10,7 +10,7 @@ inherit eutils toolchain-funcs flag-o-matic virtualx
DESCRIPTION="Lua bindings using gobject-introspection"
HOMEPAGE="http://github.com/pavouk/lgi"
-SRC_URI="https://github.com/pavouk/lgi/archive/0.7.2.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-lua/lgi/lgi-0.9.0.ebuild b/dev-lua/lgi/lgi-0.9.0.ebuild
new file mode 100644
index 000000000000..0b1ca89ba5de
--- /dev/null
+++ b/dev-lua/lgi/lgi-0.9.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/lgi-0.9.0.ebuild,v 1.1 2015/06/11 01:10:11 robbat2 Exp ${PV}.ebuild,v 1.7 2015/04/02 18:22:41 mr_bones_ Exp $
+
+EAPI=4
+
+VIRTUALX_REQUIRED="manual"
+
+inherit eutils toolchain-funcs flag-o-matic virtualx
+
+DESCRIPTION="Lua bindings using gobject-introspection"
+HOMEPAGE="http://github.com/pavouk/lgi"
+SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples test"
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/gobject-introspection
+ dev-libs/glib
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ x11-libs/cairo[glib]
+ x11-libs/gtk+[introspection]
+ ${VIRTUALX_DEPEND}
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
+ -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
+ "${S}"/lgi/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
+}
+
+src_test() {
+ Xemake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml -r docs/*
+ dodoc README.md
+ if use examples; then
+ dodoc -r samples
+ fi
+}