summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-04-17 13:39:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-04-17 13:39:08 +0000
commitb78363643ae620817d4322198fc47adefca366b2 (patch)
tree63997751725b51ecb4512b41b04bcba37f3c40a2 /dev-ml/ocurl/ocurl-0.2.1.ebuild
parentMake it compile with vdr-1.5 (diff)
downloadgentoo-2-b78363643ae620817d4322198fc47adefca366b2.tar.gz
gentoo-2-b78363643ae620817d4322198fc47adefca366b2.tar.bz2
gentoo-2-b78363643ae620817d4322198fc47adefca366b2.zip
Version bump, ~amd64, fixes compilation against curl-7.16
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-ml/ocurl/ocurl-0.2.1.ebuild')
-rw-r--r--dev-ml/ocurl/ocurl-0.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ocurl-0.2.1.ebuild b/dev-ml/ocurl/ocurl-0.2.1.ebuild
new file mode 100644
index 000000000000..ac64262995f7
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.2.1.ebuild,v 1.1 2007/04/17 13:39:08 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://sourceforge.net/projects/ocurl"
+LICENSE="MIT"
+SRC_URI="mirror://sourceforge/ocurl/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=net-misc/curl-7.9.8
+dev-libs/openssl"
+RDEPEND="$DEPEND"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ econf --with-findlib || die
+ emake -j1 all || die
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc COPYING
+ use doc && dodoc examples/*.ml
+}