summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-23 08:59:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-23 08:59:54 +0000
commit953d6e53d363cc2fcba4857270bd9ea6e78a0f70 (patch)
treebddef1bd741e5f2c771746548bbce362cc4296c4 /dev-ml/opam
parentversion bump (diff)
downloadgentoo-2-953d6e53d363cc2fcba4857270bd9ea6e78a0f70.tar.gz
gentoo-2-953d6e53d363cc2fcba4857270bd9ea6e78a0f70.tar.bz2
gentoo-2-953d6e53d363cc2fcba4857270bd9ea6e78a0f70.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/ChangeLog9
-rw-r--r--dev-ml/opam/opam-1.2.1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-ml/opam/ChangeLog b/dev-ml/opam/ChangeLog
index ea9ad61840c1..cd1d264083bf 100644
--- a/dev-ml/opam/ChangeLog
+++ b/dev-ml/opam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/opam
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/opam/ChangeLog,v 1.1 2014/10/29 09:05:04 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/opam/ChangeLog,v 1.2 2015/03/23 08:59:54 aballier Exp $
+
+*opam-1.2.1 (23 Mar 2015)
+
+ 23 Mar 2015; Alexis Ballier <aballier@gentoo.org> +opam-1.2.1.ebuild:
+ version bump
*opam-1.2.0 (29 Oct 2014)
diff --git a/dev-ml/opam/opam-1.2.1.ebuild b/dev-ml/opam/opam-1.2.1.ebuild
new file mode 100644
index 000000000000..5958a04b6d0d
--- /dev/null
+++ b/dev-ml/opam/opam-1.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/opam/opam-1.2.1.ebuild,v 1.1 2015/03/23 08:59:54 aballier Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ dev-ml/dose3:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}