summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-19 13:14:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-19 13:14:56 +0000
commitd02fe3c896d662e9fad9c92ce96c4c6e8f4ffa93 (patch)
treecc01f18368339acfb486b624883c593ab7432cac /dev-ml/pomap
parentversion bump (diff)
downloadgentoo-2-d02fe3c896d662e9fad9c92ce96c4c6e8f4ffa93.tar.gz
gentoo-2-d02fe3c896d662e9fad9c92ce96c4c6e8f4ffa93.tar.bz2
gentoo-2-d02fe3c896d662e9fad9c92ce96c4c6e8f4ffa93.zip
remove old
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/pomap')
-rw-r--r--dev-ml/pomap/ChangeLog6
-rw-r--r--dev-ml/pomap/files/pomap-3.0.1-ocaml-4.01.patch31
-rw-r--r--dev-ml/pomap/pomap-3.0.1.ebuild34
3 files changed, 5 insertions, 66 deletions
diff --git a/dev-ml/pomap/ChangeLog b/dev-ml/pomap/ChangeLog
index b7baa45da1bb..44a3acb7bffa 100644
--- a/dev-ml/pomap/ChangeLog
+++ b/dev-ml/pomap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/pomap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.33 2014/01/19 13:14:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.34 2014/01/19 13:14:56 aballier Exp $
+
+ 19 Jan 2014; Alexis Ballier <aballier@gentoo.org> -pomap-3.0.1.ebuild,
+ -files/pomap-3.0.1-ocaml-4.01.patch:
+ remove old
*pomap-3.0.3 (19 Jan 2014)
diff --git a/dev-ml/pomap/files/pomap-3.0.1-ocaml-4.01.patch b/dev-ml/pomap/files/pomap-3.0.1-ocaml-4.01.patch
deleted file mode 100644
index b0d7bfa42605..000000000000
--- a/dev-ml/pomap/files/pomap-3.0.1-ocaml-4.01.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Dummy find implementation required by ocaml 4.01.
-
-https://bitbucket.org/mmottl/pomap/issue/1/pomap-301-does-not-build-with-ocaml-401
-
-
-Index: pomap-3.0.1/lib/ptset.ml
-===================================================================
---- pomap-3.0.1.orig/lib/ptset.ml
-+++ pomap-3.0.1/lib/ptset.ml
-@@ -336,6 +336,8 @@ let rec max_elt = function
- | Leaf k -> k
- | Branch (_,_,s,t) -> max (max_elt s) (max_elt t)
-
-+let find e t = if exists (fun x -> (x = e)) t then e else raise Not_found
-+
- (*s Another nice property of Patricia trees is to be independent of the
- order of insertion. As a consequence, two Patricia trees have the
- same elements if and only if they are structurally equal. *)
-Index: pomap-3.0.1/lib/ptset.mli
-===================================================================
---- pomap-3.0.1.orig/lib/ptset.mli
-+++ pomap-3.0.1/lib/ptset.mli
-@@ -70,6 +70,8 @@ val partition : (elt -> bool) -> t -> t
-
- val split : elt -> t -> t * bool * t
-
-+val find : elt -> t -> elt
-+
- (*s Warning: [min_elt] and [max_elt] are linear w.r.t. the size of the
- set. In other words, [min_elt t] is barely more efficient than [fold
- min t (choose t)]. *)
diff --git a/dev-ml/pomap/pomap-3.0.1.ebuild b/dev-ml/pomap/pomap-3.0.1.ebuild
deleted file mode 100644
index 748278f36141..000000000000
--- a/dev-ml/pomap/pomap-3.0.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-3.0.1.ebuild,v 1.6 2013/08/19 16:19:50 aballier Exp $
-
-EAPI=5
-
-OASIS_BUILD_DOCS=1
-
-inherit eutils oasis
-
-DESCRIPTION="Partially Ordered Map ADT for O'Caml"
-HOMEPAGE="http://bitbucket.org/mmottl/pomap"
-SRC_URI="http://bitbucket.org/mmottl/pomap/downloads/${P}.tar.gz"
-LICENSE="LGPL-2.1-with-linking-exception"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86"
-IUSE="examples"
-
-DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.01_beta' && epatch "${FILESDIR}/${P}-ocaml-4.01.patch"
-}
-
-src_install() {
- oasis_src_install
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}