summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-06 12:01:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-06 12:01:54 +0000
commit2fbbb157a5fb7995cdc51a760d815a8216cb7e65 (patch)
tree3bffc66dae34566fbabf9c754d0b1fea76b64116 /dev-ml/pxp/pxp-1.2.3.ebuild
parentdo not compress examples, they are pointless compressed (diff)
downloadgentoo-2-2fbbb157a5fb7995cdc51a760d815a8216cb7e65.tar.gz
gentoo-2-2fbbb157a5fb7995cdc51a760d815a8216cb7e65.tar.bz2
gentoo-2-2fbbb157a5fb7995cdc51a760d815a8216cb7e65.zip
eapi5: define subslot, use slotdeps, remove useless || die, do not compress examples as they are useless compressed
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/pxp/pxp-1.2.3.ebuild')
-rw-r--r--dev-ml/pxp/pxp-1.2.3.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-ml/pxp/pxp-1.2.3.ebuild b/dev-ml/pxp/pxp-1.2.3.ebuild
index 0cfb8fafd7c9..c92ee9bb8966 100644
--- a/dev-ml/pxp/pxp-1.2.3.ebuild
+++ b/dev-ml/pxp/pxp-1.2.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.3.ebuild,v 1.5 2012/08/22 15:26:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.3.ebuild,v 1.6 2013/03/06 12:01:54 aballier Exp $
-EAPI="2"
+EAPI="5"
inherit findlib eutils
@@ -15,11 +15,11 @@ SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
LICENSE="MIT"
KEYWORDS="amd64 ~ppc x86"
-SLOT="0"
-DEPEND=">=dev-ml/pcre-ocaml-4.31
->=dev-ml/ulex-0.5
->=dev-ml/ocamlnet-0.98
->=dev-lang/ocaml-3.10.2[ocamlopt?]"
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+>=dev-ml/ulex-0.5:=
+>=dev-ml/ocamlnet-0.98:=
+>=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
RDEPEND="${DEPEND}"
IUSE="examples +ocamlopt"
@@ -32,17 +32,17 @@ src_configure() {
}
src_compile() {
- emake -j1 all || die "make all failed"
+ emake -j1 all
if use ocamlopt; then
- emake -j1 opt || die "make opt failed"
+ emake -j1 opt
fi
}
src_install() {
findlib_src_install
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
cd doc