summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-04 07:57:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-04 07:57:58 +0000
commit43913f9fe184687db7023a29b471c2adae7ba51d (patch)
tree9bc8be8f8ce5c4ef397cb9701508807bb760efe0 /dev-ml/pxp
parentp.mask sdsc-syslog (bug 239863) and openpbs-common (bug 255425) for removal (diff)
downloadgentoo-2-43913f9fe184687db7023a29b471c2adae7ba51d.tar.gz
gentoo-2-43913f9fe184687db7023a29b471c2adae7ba51d.tar.bz2
gentoo-2-43913f9fe184687db7023a29b471c2adae7ba51d.zip
version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/pxp')
-rw-r--r--dev-ml/pxp/ChangeLog9
-rw-r--r--dev-ml/pxp/pxp-1.2.1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index 729f6b53d9cd..c109dc4fab24 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.14 2008/04/19 15:38:09 aballier Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.15 2009/02/04 07:57:58 aballier Exp $
+
+*pxp-1.2.1 (04 Feb 2009)
+
+ 04 Feb 2009; Alexis Ballier <aballier@gentoo.org> +pxp-1.2.1.ebuild:
+ version bump
19 Apr 2008; Alexis Ballier <aballier@gentoo.org> -pxp-1.1.95.ebuild,
-pxp-1.1.96.ebuild:
diff --git a/dev-ml/pxp/pxp-1.2.1.ebuild b/dev-ml/pxp/pxp-1.2.1.ebuild
new file mode 100644
index 000000000000..e7d44f94e018
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.1.ebuild,v 1.1 2009/02/04 07:57:58 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ulex-0.5
+>=dev-ml/ocamlnet-0.98
+>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all || die "make all failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV EXTENSIONS README SPEC design.txt
+}