summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-24 14:00:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-24 14:00:53 +0000
commit1486dee19baf432443e09e58adc2dc044cd28afd (patch)
treefc955124248deef2f4003dca3845ae62c0e2501d /dev-ml
parentversin bump (diff)
downloadgentoo-2-1486dee19baf432443e09e58adc2dc044cd28afd.tar.gz
gentoo-2-1486dee19baf432443e09e58adc2dc044cd28afd.tar.bz2
gentoo-2-1486dee19baf432443e09e58adc2dc044cd28afd.zip
version bump
(Portage version: 2.2.0_alpha35/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-data-notation/ChangeLog8
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.4.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/ocaml-data-notation/ChangeLog b/dev-ml/ocaml-data-notation/ChangeLog
index 19d1ff1501d0..df755a1c1135 100644
--- a/dev-ml/ocaml-data-notation/ChangeLog
+++ b/dev-ml/ocaml-data-notation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-data-notation
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.1 2011/03/15 20:18:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.2 2011/05/24 14:00:53 aballier Exp $
+
+*ocaml-data-notation-0.0.4 (24 May 2011)
+
+ 24 May 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-data-notation-0.0.4.ebuild:
+ version bump
*ocaml-data-notation-0.0.3 (15 Mar 2011)
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.4.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.4.ebuild
new file mode 100644
index 000000000000..777235684e65
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.4.ebuild,v 1.1 2011/05/24 14:00:53 aballier Exp $
+
+EAPI=3
+
+inherit findlib multilib
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="https://forge.ocamlcore.org/projects/odn"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/622/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-ml/type-conv-1.5.0"
+DEPEND="${RDEPEND}
+ dev-ml/ounit[ocamlopt?]
+ dev-ml/ocaml-fileutils[ocamlopt?]"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt || die "doc install failed"
+}