summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-15 15:13:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-15 15:13:57 +0000
commit368072bdb77ca2ca4d677ba01d9e23bc787b6b82 (patch)
tree9a966405291262220049cfca44a352cf7f50391b /dev-ml
parentStable for amd64, wrt bug #434490 (diff)
downloadgentoo-2-368072bdb77ca2ca4d677ba01d9e23bc787b6b82.tar.gz
gentoo-2-368072bdb77ca2ca4d677ba01d9e23bc787b6b82.tar.bz2
gentoo-2-368072bdb77ca2ca4d677ba01d9e23bc787b6b82.zip
initial import, ebuild by Tomasz Bielaszewski and Jacques-Pascal Deplaix, bug #316185
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamldap/ChangeLog11
-rw-r--r--dev-ml/ocamldap/metadata.xml21
-rw-r--r--dev-ml/ocamldap/ocamldap-2.1.8.ebuild34
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ml/ocamldap/ChangeLog b/dev-ml/ocamldap/ChangeLog
new file mode 100644
index 000000000000..d23f4a17df7e
--- /dev/null
+++ b/dev-ml/ocamldap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamldap
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamldap/ChangeLog,v 1.1 2012/09/15 15:13:57 aballier Exp $
+
+*ocamldap-2.1.8 (15 Sep 2012)
+
+ 15 Sep 2012; Alexis Ballier <aballier@gentoo.org> +ocamldap-2.1.8.ebuild,
+ +metadata.xml:
+ initial import, ebuild by Tomasz Bielaszewski and Jacques-Pascal Deplaix, bug
+ #316185
+
diff --git a/dev-ml/ocamldap/metadata.xml b/dev-ml/ocamldap/metadata.xml
new file mode 100644
index 000000000000..b3e9b2788cec
--- /dev/null
+++ b/dev-ml/ocamldap/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <longdescription lang="en">
+Ocamldap is an implementation of the Light Weight Directory Access Protocol,
+and a set of useful tools built around it. It includes high level libraries
+for creating ldap clients and ldap servers. It also includes many of the
+auxiliary tools needed for building intelligent solutions, and interoperating
+with other directories. These include, an rfc2252 schema parser, and an schema
+checker, an ldif parser and printer, a search filter parser (but no printer
+yet), and a rudimentary ldap url parser. While including things already done
+elsewhere is fun, ocamldap adds something as well. So it implements a concept
+which tries to provide a basic unit of abstraction for managing directory data,
+called a service. A service is a bit like a stored search filter that you give
+a name. So you can ask ocamldap if an object satisfies its conditions, but
+unlike a search filter you can also ask ocamldap to MAKE an object satisfy its
+conditions. This can be really useful in distributed managment applications.
+Needless to say, more on this in the Documentation section.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocamldap/ocamldap-2.1.8.ebuild b/dev-ml/ocamldap/ocamldap-2.1.8.ebuild
new file mode 100644
index 000000000000..d452d2768541
--- /dev/null
+++ b/dev-ml/ocamldap/ocamldap-2.1.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamldap/ocamldap-2.1.8.ebuild,v 1.1 2012/09/15 15:13:57 aballier Exp $
+
+EAPI=4
+
+inherit findlib
+
+DESCRIPTION="ldap server and client library for Ocaml"
+HOMEPAGE="http://sourceforge.net/projects/ocamldap/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt doc"
+
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-ml/ocamlnet-2.2.9-r1
+ >=dev-ml/ocaml-ssl-0.4.3"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install(){
+ findlib_src_install
+ dodoc README INSTALL Changelog
+ use doc && dohtml -r doc/ocamldap/html
+}