summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-05-19 05:41:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-05-19 05:41:48 +0000
commit58dc2a614114eec2a5a7847d5a1d085258c34586 (patch)
tree608ffb1e221437b8de8ba9ccb71cb83ef97615a8 /dev-ml
parentMoved back from sunrise. See Bug #109695 (diff)
downloadgentoo-2-58dc2a614114eec2a5a7847d5a1d085258c34586.tar.gz
gentoo-2-58dc2a614114eec2a5a7847d5a1d085258c34586.tar.bz2
gentoo-2-58dc2a614114eec2a5a7847d5a1d085258c34586.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camomile/ChangeLog9
-rw-r--r--dev-ml/camomile/camomile-0.7.3.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index a4c28766e1cb..67b0c8d40899 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camomile
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.18 2009/09/01 08:48:32 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.19 2010/05/19 05:41:48 aballier Exp $
+
+*camomile-0.7.3 (19 May 2010)
+
+ 19 May 2010; Alexis Ballier <aballier@gentoo.org> +camomile-0.7.3.ebuild:
+ version bump
01 Sep 2009; Alexis Ballier <aballier@gentoo.org> -camomile-0.7.1.ebuild:
remove old
diff --git a/dev-ml/camomile/camomile-0.7.3.ebuild b/dev-ml/camomile/camomile-0.7.3.ebuild
new file mode 100644
index 000000000000..275ade4595cd
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.7.3.ebuild,v 1.1 2010/05/19 05:41:48 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://camomile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}