summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-07 20:50:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-07 20:50:07 +0000
commit76cd9d224e9269d8305cb75cab3496349cd47d36 (patch)
tree225509bf8825a4ed91085d8574b3c9e378335920 /dev-ml
parentadd profiles for 9.1, from the bsd overlay based on 9.0 ones (diff)
downloadgentoo-2-76cd9d224e9269d8305cb75cab3496349cd47d36.tar.gz
gentoo-2-76cd9d224e9269d8305cb75cab3496349cd47d36.tar.bz2
gentoo-2-76cd9d224e9269d8305cb75cab3496349cd47d36.zip
initial import, ebuild by Guillaume Horel and Jacques-Pascal Deplaix, bug #406661
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/eliom/ChangeLog11
-rw-r--r--dev-ml/eliom/eliom-2.2.2.ebuild61
-rw-r--r--dev-ml/eliom/metadata.xml8
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-ml/eliom/ChangeLog b/dev-ml/eliom/ChangeLog
new file mode 100644
index 000000000000..a8e3f407ee03
--- /dev/null
+++ b/dev-ml/eliom/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/eliom
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/eliom/ChangeLog,v 1.1 2012/08/07 20:50:07 aballier Exp $
+
+*eliom-2.2.2 (07 Aug 2012)
+
+ 07 Aug 2012; Alexis Ballier <aballier@gentoo.org> +eliom-2.2.2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by Guillaume Horel and Jacques-Pascal Deplaix, bug
+ #406661
+
diff --git a/dev-ml/eliom/eliom-2.2.2.ebuild b/dev-ml/eliom/eliom-2.2.2.ebuild
new file mode 100644
index 000000000000..8ffd5ca6529e
--- /dev/null
+++ b/dev-ml/eliom/eliom-2.2.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/eliom/eliom-2.2.2.ebuild,v 1.1 2012/08/07 20:50:07 aballier Exp $
+
+EAPI=4
+
+inherit eutils multilib findlib
+
+DESCRIPTION="A web framework to program client/server applications"
+HOMEPAGE="http://ocsigen.org/eliom/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt ocamlduce"
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/js_of_ocaml-1.2
+ >=www-servers/ocsigenserver-2.1
+ >=dev-ml/tyxml-2.1[ocamlduce?]
+ >=dev-ml/deriving-ocsigen-0.3
+ dev-ml/react
+ dev-ml/ocaml-ssl
+ dev-ml/calendar"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sh configure \
+ --prefix "/usr" \
+ --docdir "/usr/share/doc/${PF}/html" \
+ --mandir "/usr/share/man/" \
+ --temproot "${ED}" \
+ --libdir "/usr/$(get_libdir)/ocaml" \
+ $(use_with ocamlduce) || die "configure failed"
+}
+
+src_compile() {
+ if use ocamlopt ; then
+ emake
+ else
+ emake byte
+ fi
+ use doc && emake doc -j1
+}
+
+src_test() {
+ emake tests.byte
+ use ocamlopt && emake tests.opt
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake install
+ else
+ emake install.byte
+ fi
+ use doc && emake install.doc
+ dodoc CHANGES README
+}
diff --git a/dev-ml/eliom/metadata.xml b/dev-ml/eliom/metadata.xml
new file mode 100644
index 000000000000..ea89b16d367e
--- /dev/null
+++ b/dev-ml/eliom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <use>
+ <flag name='ocamlduce'>Enables ocamlduce XML typechecking.</flag>
+ </use>
+</pkgmetadata>